Closed Bug 19516 Opened 20 years ago Closed 20 years ago

Problem with long input to text-boxes

Categories

(Core :: DOM: Editor, defect, P3, blocker)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 13407

People

(Reporter: joel.jacobson, Assigned: kinmoz)

Details

Attachments

(1 file)

You can't enter more input to a text-box than it's sized for.
I mean, you can't "see" what text you type in after the number of chars it was
originally sized for has been reached. It will "jump back" to the beginning so
you can't see what you type in.
Assignee: davidm → beppe
Component: HTML Dialogs → Editor
Nothing to to with html dialogs. change comonent and reassign to editor
Joel, I can't reproduce this on a win32 platform. What platform are you on and
what build date are you using?
OS: other → Linux
I'm using Caldera OpenLinux v2.3, kernel 2.2.13 (i686).
The build date is: 1999111520
But this is not the only problem with textboxes. Also line feed doesn't work for
me. If I press enter right now, nothing will happend, I will have to press the
ENTER-key twice before Mozilla move the cursur down.
thanks for the update, and we already have a bug open dealing with the enter key
issue. One other question for you -- are you talking about the sing;e line input
text element or are you talking about the textarea (multi-line) form element?
The enter key problem occurs in textareas. (You cannot have mutiple lines in
single lined textboxes, so I don't know if this bug also applies to them).
I was asking in regards to the scrolling issue, not the enter key issue. Are you
encountering the scrolling issue with <textarea> elements or with <input
type=text> elements?
* Vertical scrolling in a <textarea> element does not work.
* Scrolling is no problem in <input type=text> elements.
(In my comment from 11/23/99 03:33 I ment <input type=text> and not <textarea>
elements.)
ok, let me test my understanding -- your original entry on 11/21 refers to
scrolling in a textarea element. Meaning if the textarea is defined as <textarea
cols=5 rows=20> for example, the 6th and greater lines cannot be accessed. Is
that correct?
No. My original bug report explaned the problem with <input type=text> elements.
great, that is what I originally thought, so the issue is scrolling within a
<input type=text> element, which means my previously attached test case was
correct.
Assignee: beppe → kin
Target Milestone: M12
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This is a dup of bug #18353. We are turning on Gfx Scrollbars tonight which
should make this problem disappear.

*** This bug has been marked as a duplicate of 18353 ***
Status: RESOLVED → REOPENED
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
*** This bug has been marked as a duplicate of 13407 ***
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.