In <select> space taken by padding should be painted with tag specified background color

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: goldicus1970, Unassigned)

Tracking

({platform-parity, testcase})

Trunk
x86
Windows 2000
platform-parity, testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

In the testcase <select> element has a 4px padding: in Mozilla 1.2 / Win it's
correctly painted with gray, instead  using Mozilla / Win 1.3b padding space is
painted with white. According to CSS spec padding space should have the same
colour of element's background color. Just take a look at the two screenhot
provided with the test page to see what i mean.

Reproducible: Always

Steps to Reproduce:
1. Open testacse URL
2. ...and see by yourself


Actual Results:  
There's a white stripe around select contents, just inside the border.

Expected Results:  
Select bg should the painted twith gray when it doesn't have focus.

Comment 1

16 years ago
Yup, looks like a bug to me, and I can't find any duplicates. Confirming.
There appears to be no difference between Standards and Quirks mode either. Will
attach minimal testcase.

Can anyone track down exactly where this occurred between 1.2.1 and 1.3b?

Not sure if the bug belongs here or in "Style System"; probably the latter.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 2

16 years ago
Created attachment 115758 [details]
Minimal testcase

The red background should extend all the way to the edge of the select, but it
doesn't.
This is windows-native-control-only.
Keywords: pp
Priority: -- → P4
Target Milestone: --- → Future
Is this a problem in a current build now that bug 224974 is fixed?
Depends on: 181490
Assignee: core.layout.form-controls → win32
Component: Layout: Form Controls → GFX: Win32
Priority: P4 → --
QA Contact: desale → ian
Target Milestone: Future → ---

Comment 5

15 years ago
This should be fixed by bug 224974 (check-in of bug 181490).
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.