In multi-line select list, background color not rendering according to style; defaults to white

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: omerk, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows 2000
regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031106 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031106 Firebird/0.7+

See example at http://www.merkconsulting.com/test01.html. This renders ok in NS
7.1 and earlier mozilla build but is incorrect in latest mozilla and fb builds.

Reproducible: Always

Steps to Reproduce:
1. See example at http://www.merkconsulting.com/test01.html

Actual Results:  
Wrong bg color rendered

Expected Results:  
Rendered bg color as per style

Comment 1

15 years ago
WFM, 2003-11-06-05 trunk Linux
Assignee: parser → form
Severity: normal → minor
Component: HTML: Parser → Layout: Form Controls
QA Contact: ian

Comment 2

15 years ago
Created attachment 134985 [details]
Screenshot of incorrect behaviour

I see the same bug, with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.6a) Gecko/20031107 Firebird/0.7+
Dup of another one of those "native theme" issues with Windows form controls.
Whiteboard: DUPEME

Comment 4

15 years ago
*** Bug 225066 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
attachment 137106 [details] can be used to test this bug.

*** This bug has been marked as a duplicate of 227920 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

15 years ago
*** Bug 227920 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
Created attachment 137354 [details]
test case

CONFIRMING: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031212

(there should be a css-forms specification, really!)
Unfortunately CSS makes no difference, still the same error.
For as far as I have been experimenting with CSS on the inut it's only the
background-color that isn't respected. All CSS font and size properties are
displayed  correctly.

Comment 9

15 years ago
*** Bug 228551 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
Regression, per dup bug 228551.
Possibly a dup of bug 181490, which seems to have morphed into this issue.
Keywords: regression
*** Bug 230404 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
Confirming based on duplicates
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

15 years ago
*** Bug 231459 has been marked as a duplicate of this bug. ***
This is windows-only; reassigning accordingly.
Assignee: core.layout.form-controls → win32
Component: Layout: Form Controls → GFX: Win32
*** Bug 231599 has been marked as a duplicate of this bug. ***
Created attachment 139523 [details]
Another testcase

the select-box should have a black background. The foreground color is white,
which is why you can't see anything until you select an item.

Comment 17

15 years ago
*** Bug 231713 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Whiteboard: DUPEME

Comment 18

15 years ago
At least under WinXP it seems that both the list controls and the combo box have
their backgrounds drawn in nsCSSRendering::PaintBackgroundWithSC() using theming
(displayData->mAppearance != 0), which doesn't support using different colors.
The combobox seems to get the color from a child which is painted using
PaintBackgroundColor() (displayData->mAppearance == 0). 
Disclaimer: I don't have have a good grip on the whole process and I don't even
have any idea what mAppearance is.

Native form controls are a feature, not a bug.  However, we should either ignore
the foreground color or use the background color.

Comment 20

15 years ago
I know, but if we want different background colors, we need to paint them. Btw,
they multiline listboxes don't have native looking scrollbars at least when
using the Mozilla Modern theme and WinXP theming.

Comment 21

15 years ago
*** Bug 234439 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
The key issue here is that a <select> without a size attribute IS rendered in
the proper color.  This should help narrow down where the problem is.  I
encountered this bug myself for the first time today and am going to have to run
a filter on my web proxy to 'fix' web sites until this is fixed in mozilla.

Updated

15 years ago
Keywords: testcase

Comment 23

15 years ago
In reality they are two different controls. 
isn't there a style="?" to replace size=nr  in <select> ?
*** Bug 235749 has been marked as a duplicate of this bug. ***
Note that the patch in bug 181490 fixes this bug.

Comment 27

15 years ago
*** Bug 228851 has been marked as a duplicate of this bug. ***
Fixed by the patch that got checked in for bug 181490
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
*** Bug 237443 has been marked as a duplicate of this bug. ***

Comment 30

14 years ago
*** Bug 237025 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.