mozilla exits immediately with exit status = 1 if user is not root

VERIFIED DUPLICATE of bug 163524

Status

--
blocker
VERIFIED DUPLICATE of bug 163524
16 years ago
14 years ago

People

(Reporter: barninga, Assigned: ssu0262)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

after removing a working 1.2.1 installation (installed in /usr/local/mozilla
through the graphical installer) and installing 1.3b (in the same way, complete
install), mozilla exits immediately with status = 1 if launched by a regular
user; it works fine only for root. removing 1.3b and reinstalling 1.2.1 did not
solve: both version now exit immediately (an empty $HOME/.mozilla dir is
created. anyway having a previously working $HOME/.mozilla dir does not avoid
the problem).

Reproducible: Always

Steps to Reproduce:
1. install 1.2.1 through mozilla-installer
2. delete /usr/local/mozilla
3. install 1.3b through mozilla installer: here appears the problem

4. repeat step 2
5. reinstall 1.2.1 through mozilla installer: the problem remains

Actual Results:  
i can't use any version of mozilla: it always exits after a fraction of a second
with status = 1. it only works if launched by root. it happens for any regula
user defined in the system, both using the existing $HOME/.mozilla dir or after
deleting it.

Expected Results:  
it should open its gui and work as usual

it did not happen on a linux box where mozilla had never been installed before
Installer bug....
Assignee: asa → ssu
Component: Browser-General → Installer
QA Contact: asa → bugzilla
(Reporter)

Comment 2

16 years ago
yes it sounds like an installer bug. anyway i tried to check if it could be an
environemnt problem. it shouldn't be, as i compared root's environment with
regular users' one and they are coherent and very similar, and all env vars
concerning mozilla hold the same values.
i also modified the regular user env so taht it be identical to root's one
(except for readonly vars and HOME, LOGNAME, and a few more, and the problem
persists.

as retcode 1 should mean "operation not permitted", i chmoded mozilla-bin to
1755, but i got a "file not found" error while tring to load a shared library
which *is* in the mozilla dir.

maybe understanding what exactly mozilla-bin is doing when the error occurs
could be useful.

how can i help?

Comment 3

16 years ago
this sounds like bug 163524.  do you have MOZILLA_FIVE_HOME set?  does the
mozilla/components directory have execute permission?

that bug should not be a problem anymore (with latest-1.3, or current trunk)
because bug 144311 has been fixed.
(Reporter)

Comment 4

16 years ago
ok, the problem was in "components" subdir permissions: it was 644.
i chmoded it to 755 and mozilla is working for all users now.

so i think i installed moz 1.2.1 to an existing tree where subdirs' permissions
were ok; but the i deleted the tree before installing moz 1.3b, so the installer
bug showed up. this means that also 1.2.1 installer has the same bug.

MOZILLA_FIVE_HOME and MOZILLA_HOME were both correctly set to /usr/local/mozilla

sorry for posting a dup; i searched bugzilla with keywords like "exits" "status
= 1" etc. and found nothing.

thanks all for your work - i close this bug as duplicate of 163524

*** This bug has been marked as a duplicate of 163524 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v dupe.

BTW: that was bug 144331, not 144311
bugs like this are hard to diagnose, so don't worry too much about the dupe.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.