Clearing Download Manager History doesn't work

VERIFIED FIXED in mozilla1.5

Status

()

Toolkit
Downloads API
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: djst, Assigned: mconnor)

Tracking

({privacy})

unspecified
mozilla1.5
x86
All
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
If you click on the Clear button under Download Manager History, only half of
the downloaded items are cleared.

Steps to reproduce:
1. Open the Download sidebar (Ctrl+E)
2. Download a few small files if you don't have a download history already
3. Select Tools > Options..., click Privacy, Download Manager History, and then
click Clear.

Actual results:
Only half of the items are removed from the list.
(Assignee)

Comment 1

15 years ago
taking, patch coming
Assignee: blakeross → mconnor
(Assignee)

Comment 2

15 years ago
Created attachment 128095 [details] [diff] [review]
patch to fix Clear Downloads functionality

this method works, and goes along with how the clear cookies function works. 
Why the existing method doesn't work isn't readily evident to me,  but given
that the cookies removal could use this method as well and doesn't, I figure
this is the best fix for the moment
(Assignee)

Comment 3

15 years ago
Created attachment 128096 [details] [diff] [review]
patch to fix Clear Downloads functionality

this method works, and goes along with how the clear cookies function works. 
Why the existing method doesn't work isn't readily evident to me,  but given
that the cookies removal could use that method as well and doesn't, I figure
this is the best fix for the moment
(Assignee)

Updated

15 years ago
Attachment #128095 - Attachment is obsolete: true

Comment 4

15 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 5

15 years ago
verified with 20030721 build on W2K
Status: RESOLVED → VERIFIED

Updated

15 years ago
Target Milestone: --- → Firebird0.7

Comment 6

15 years ago
*** Bug 213183 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.