MySQL 4 Table Locking appears to be different

RESOLVED FIXED in Bugzilla 2.18

Status

()

RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: dantealiegri, Assigned: jacob)

Tracking

unspecified
Bugzilla 2.18
x86
Linux

Details

(Whiteboard: \, URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030126

I have 4.0.2 installed.
the options in the bugzilla documention for mysql won't give it permissions 
to lock the tables.
it appears that in 4, a user needs LOCK TABLES ON *.* in order to lock tables.

Anyone else with 4, could you please double check this?

Reproducible: Always

Steps to Reproduce:
1.Run Mysql4
2.Install Bugzilla following instructions
3.See Bugzilla fail

Actual Results:  
Bugzilla fails to lock the shadowdb and tokens tables when you go to, say query.cgi.

Expected Results:  
Bugzilla should have no problem locking the tables.
Yep, thats what the docs say.

checksetup.pl may want SHOW DATABASES too, although that can probably be worked
arround.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Post from the newsgroup with more info...

-----------
To: mozilla-webtools@mozilla.org
From: Eric Trager <etrager@nospam.cybernothing.org.netscape.com>
Newsgroups: netscape.public.mozilla.webtools
Subject: Re: bugzilla installation: newbie needs help
Date: 21 Mar 2003 15:42:30 GMT

[....]

I just went through very similar frustration with my new bugzilla install. 
THere is an error in the step-by-step install documentation. In 4.1.8, it 
discusses granting privileges for the DB, but since MySQL is now 4.0.x, 
additional privileges need to be granted.

After I had the same failure, I found a reference online and went back 
into mysql as root and did

mysql> GRANT LOCK TABLES,CREATE TEMPORARY 
TABLES,SELECT,INSERT,UPDATE,DELETE,INDEX,ALTER,CREATE,DROP,REFERENCES ON 
bugs.* TO bugs@localhost IDENTIFIED BY 'thepassword';
Query OK, 0 rows affected (0.00 sec)

mysql> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.00 sec)

The doc leaves out the LOCK TABLES and CREATE TEMPORARY TABLES entries. 
Once I added those privileges, I was able to access the query feature, and 
the edit parameters link mentioned in the docs suddenly appeared.

- eT
--------------
I wonder if existing installations that upgrade their MySQL to 4.0.x are going
to have to deal with this, or if "mysql_fix_privilege_tables" (as recommended in
http://www.mysql.com/doc/en/Upgrading-from-3.23.html) is sufficient.

Comment 4

16 years ago
Could you please update the docs for 2.16.2, this cost me some time while
first-installing... :-/
I guess..

This shouldn't affect old installs though, since the mysql privilage upgrade
script should be handling this - does it?
Whiteboard: [wanted for 2.16.3]
2.16 is still the supported stable branch, and as such, Jake has instructions to
apply any fixes he makes to the documentation to both the 2.16 branch and the
trunk unless that change is only applicable to the trunk.  This is one of those
things that would obviously apply to both.
(Assignee)

Comment 7

16 years ago
Added a note to both the 2.16 docs and the tip docs about the two new
permissions Bugzilla requires in MySQL 4.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
Whiteboard: [wanted for 2.16.3] → \
*** Bug 202947 has been marked as a duplicate of this bug. ***
*** Bug 220996 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
Greetings, the ALTER priv is also needed when upgrading from an existing
database.  Somehow that needs to be documented.

QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.