Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 13325
18 years ago
18 years ago

People

(Reporter: Matthew Schultz, Assigned: pnunn)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Javascript isn't caching images for mouseovers and picture changes.

Updated

18 years ago
Assignee: gagan → vidur
Component: Cache → DOM Level 0

Comment 1

18 years ago
Sounds DOM related. => Vidur.

Comment 2

18 years ago
This could also be simply the lack of any caching at all, for any files -
which still seems to be the case.

That is bug 8305 - "[Arch] Cache needs to be implemented." - P2, M12, ASSIGNED.
Caching of images called by javascript may have additional wrinkles, but
testing for that will have to wait.

The conservative move here would be to make this bug depend on bug 8305,
so that this will get an independant check once 8305 is fixed.

Updated

18 years ago
Summary: Cached images → [wip+rods]Cached images

Updated

18 years ago
Assignee: vidur → fur

Comment 3

18 years ago
It is not that JS needs to cache images, it's that we need an image cache. Then
when JS goes to get an image it comes from the cache, but this is transparent to
JS. I am assigning this over to fur as an additional test case for the image
cache or he can mark it as a duplicate.

Updated

18 years ago
Summary: [wip+rods]Cached images → Cached images

Comment 4

18 years ago
changed summary

Comment 5

18 years ago
First, it's not clear what the bug is since there's no description of the
problem in the report.

Second, the network memory cache has nothing to do with the image
cache.  Assigning to pnunn...

Updated

18 years ago
Assignee: fur → pnunn
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 6

18 years ago
rods:

There is an image cache. It was never disabled.
Currently the reload policy on all images
(except animated gifs) is set to get the
image from the cache if it exists in the cache.
If not, get it from the server.

Animated gifs get the image from the netlib cache for every
loop. Since this cache doesn't exist yet, the image is
retrieved from the server.

I'm closing this as invalid, unless someone can further
clarify the problem.
-pn
(Assignee)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Assignee)

Comment 7

18 years ago
I'm reopening this one. Just because the analysis of
the problem is incorrect doesn't mean there isn't a problem
with js images.

-pn

Updated

18 years ago
Resolution: INVALID → ---

Comment 8

18 years ago
Clearing INVALID resolution due to reopen.

Comment 9

18 years ago
Sounds like a dup of 13325.
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 10

18 years ago
I agree. It does sound like a dupe.
-p

*** This bug has been marked as a duplicate of 13325 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
verified duplicate of 13325
You need to log in before you can comment on or make changes to this bug.