Entity declared in DTD is not used in XML while transforming through XSLT

RESOLVED DUPLICATE of bug 22942

Status

()

Core
XSLT
RESOLVED DUPLICATE of bug 22942
15 years ago
15 years ago

People

(Reporter: Stefan Champailler, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

let backgrounder.dtd a dtd file where the entity nbsp is declared like this :

<!ENTITY % nbsp "&#38;#160;">

A document like this :

<?xml version="1.0" encoding="iso-8859-1" ?>
<?xml-stylesheet type="text/xsl" href="component_layout_1_0.xsl"?>

<!DOCTYPE backgrounder SYSTEM 'backgrounder.dtd'> 

<backgrounder>
AANon breakable space : [&nbsp;]
</backgrounder>

won't be XSLT transformed by Mozilla. However, if I add the entity declaration
right in the xml, like this :

<!DOCTYPE backgrounder SYSTEM 'backgrounder.dtd'
[ <!ENTITY nbsp "&#38;#160;"> ]
>


everything is just fine.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

*** This bug has been marked as a duplicate of 22942 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
If you came here from a checkin comment for txMozillaXMLOutput.cpp, you're 
actually looking for bug 195945.
You need to log in before you can comment on or make changes to this bug.