With Camino already opened, launching a second Camino app numerous times will display multiple 'Can't Launch Camino' alert dialogs

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
General
P2
normal
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Chris Petersen, Assigned: Simon Fraser)

Tracking

unspecified
Camino0.9
PowerPC
Mac OS X

Details

(Reporter)

Description

15 years ago
Build: 2003-03-04-19
Platform: Mac OS 10.2.4
Expected Results: Only open dialog should be displayed
What I got: Multiple dialogs are displayed (a dialog for every time I launched
the application)

Steps to reproduce:

1) Have two copies of Camino
2) Launch the first copy
3) Launch the second copy multiple times
4) You should get a alert dialog for each time you have launched the second copy
of Camino.
5) This can be a problem since clicking on the Quit button of this dialog can
result in a crash.
(Assignee)

Comment 1

15 years ago
Taking
Assignee: saari → sfraser
(Reporter)

Comment 2

15 years ago
Still occurs in the 2003-08-10-02 camino NB.

Comment 3

13 years ago
WFM: 2005031508

/Applications/Camino.app/Contents/MacOS/Camino

Only spawns one alert dialog... I'll reopen if others can reproduce.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

13 years ago
It goes like this:
1. have camino running
2. launch another copy of camino; it puts up the dialog
3. click on the dock icon of that new cope. For every click, it puts up a new
dialog.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

13 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

13 years ago
Priority: -- → P2
Target Milestone: --- → Camino0.9
(Assignee)

Comment 5

13 years ago
Fixed.
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
*** Bug 271624 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.