Filter query fields are incomplete

RESOLVED DUPLICATE of bug 234222

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 234222
15 years ago
10 years ago

People

(Reporter: Neil Katin, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210


The filter query fields (status, to, cc, etc) have not been updated for
recent extensions to mozilla, as well as missing one or two basic
fields.  This came up for me when I turned on spam filtering, with
"move to junk folder"; the messages were marked as deleted in my inbox but
still marked as "new" in the inbox.

"No problem" I thought; I'll just use filtering to mark those messages
as read.

Alas, there is no way to query for either messages marked as junk or messages
marked as deleted.

So, here's my list of missing "match" fields:

    the deleted field is set/unset
    the junk field is set/unset
    the label is/is not (label list)
    the flag is set/unset
    the size is equal/greater/less than
    

    

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
junk and label filters are now implemented.

Filter by size is bug  19402
Filter by flag is bug 234222

Marking as duplicate of bug 234222

*** This bug has been marked as a duplicate of 234222 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.