Last Comment Bug 196405 - Can't set fonts for Cursive & Fantasy in Preference
: Can't set fonts for Cursive & Fantasy in Preference
Status: VERIFIED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: x86 All
: -- enhancement with 1 vote (vote)
: ---
Assigned To: Blake Ross
: Asa Dotzler [:asa]
:
Mentors:
: 515554 515555 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-07 16:32 PST by john russell
Modified: 2011-06-12 07:14 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description john russell 2003-03-07 16:32:55 PST
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030304 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030304 Phoenix/0.5

summary says it all -- both netscape and mozilla let you set 
all the css family  defaults...  phoenix is incomplete in this respect.

Reproducible: Always

Steps to Reproduce:
1. enter preferences  fonts dialog 
2. note missing scroll box zones
3.

Actual Results:  
miffed 

Expected Results:  
to see the scroll box selectors for the cursive and fantasy families
Comment 1 noririty 2003-03-30 05:08:50 PST
->Severity: enhancement
->OS: All

Changing summary.
Waiting for developer's review.
I suggest WONTFIX.
Comment 2 Pham 2003-04-20 07:57:32 PDT
I think they did this to save space for COLORS
Comment 3 john russell 2003-04-27 10:25:44 PDT
Just noticed that the fantasy font default selects the first in alpha 
order.  this is unfortunate in my case as i just installed a new package
of fonts and one of them  was  Algerian .....   
Since there is no option to change fantasy font choice,  at least 
the control freaks should select one that uses latin character set
so at least the text is readable .... 
Comment 4 Mike Connor [:mconnor] 2003-07-08 20:15:49 PDT
use about:config :) creating "font.name.fantasy.x-western" with the value of the
font name you want should do the trick.  The fantasy prefs don't even exist in
my version of Firebird, so I'm guessing the pref was actually stripped out. 
Therefore with no default, it seems that Mozilla will pick the first font in
your fonts directory.

As for the bug, since Ben intentionally removed it from the UI and it can still
be manually configured for those who need it, this should be WONTFIX.

(If I'm wrong on this and the pref doesn't even work, please reopen this bug.)
Comment 5 noririty 2003-07-08 23:34:30 PDT
v.
Comment 6 john russell 2003-07-09 05:42:04 PDT
from ve3ll@rac.ca
ok -- i will try to do this ---
i am interested in the comment that ben removed it from the UI.
do you mean that at one time it WAS configuarble from the browser?
Even though few would want to do it there should be a gui mechanism.
using the method you describe  harks back to the days of 
msDos and mysterious incantations and knowledge by the wizard
 to get things done ....  basic choice selections of fonts and colors  
    should be left to user (with easy methods) if he chooses and
 defaulting to appropriate values just in case he doesn't.... 
neither is done in this situation...  Just a SURFER view...
Comment 7 Mark Purtill 2004-05-11 22:01:05 PDT
I agree with john russell: the default is wrong, and the user can't fix it
without looking thru bugzilla.  That sound like a bug to me, and I don't
understand how "wontfix" is a sensible response.
Comment 8 Michael Dell 2007-03-27 21:08:56 PDT
These parameters (Cursive and Fantasy) are configurable in Mozilla, but not Firefox, and I currently get inconsistent results (different fonts) wherever Fantasy is specified. Sometimes I'll get a page with one font, sometimes with another.
Comment 9 Kevin Brosnan 2009-09-09 18:30:38 PDT
*** Bug 515554 has been marked as a duplicate of this bug. ***
Comment 10 Wayne Mery (:wsmwk, NI for questions) 2011-01-05 22:34:05 PST
*** Bug 515555 has been marked as a duplicate of this bug. ***
Comment 11 [Baboo] 2011-06-12 07:14:50 PDT
Why is this a WONTFIX?

Note You need to log in before you can comment on or make changes to this bug.