sidebar name list becomes bottom-justified

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: tkil-mozilla, Assigned: neil)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312

It seems that the sidebar gets confused about where to scroll to,
and what to display there, switching between channels.  Bug present

Reproducible: Always

Steps to Reproduce:
1. /server irc.mozilla.org
2. /join #mozilla
   large number of users populate the sidebar.
3. /join #chatzilla
   small number (less than one screenful, probably important)
   populate sidebar
4. switch back to #mozilla.
5. scroll down the list of names a bit,
6. select one of the users down the list.
7. switch back to #chatzilla.  
Actual Results:  
Short lists of users are displayed at bottom of sidebar, instead
of near top.

Expected Results:  
Short user lists (less than a screenful) should probably be displayed
top-aligned in the sidebar.

Reproduced on 1.3 final, chatzilla 0.8.23 (couldn't get 0.8.24 to
install on either OSX or Linux!).  Reproduced on Linux (RH8.0 +
updates) and Mac OS X (10.2.4).

(And yes, I know that install on OSX is disabled on purpose
right now; I was just explaining why I hadn't tried it with the
latest-and-greatest, especially as there were some fixes in 0.8.24
regarding name sidebar display.)

Comment 1

16 years ago
*** Bug 199304 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All

Comment 2

16 years ago
Created attachment 118754 [details] [diff] [review]
patch v1

nsTreeSelection::ClearSelection() didn't reset mCurrentIndex.

Updated

16 years ago
Attachment #118754 - Flags: review?(hyatt)

Comment 3

15 years ago
0.9.28 doesn't have this bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
This bug is reproduced with 2003111005-trunk/Linux, cz0.9.47.
Reopening bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 5

15 years ago
I *think* this is a bug in the Mozilla listbox code (since in 1.5 release, I get
the users too high up, mousewheel fixes it), and should either be moved / dupped
to the correct component or bug, or marked INVALID, since there is nothing wrong
with what ChatZilla's doing.
(Assignee)

Updated

15 years ago
Depends on: 233158
(Assignee)

Comment 6

15 years ago
Created attachment 140804 [details] [diff] [review]
Fix chatzilla for earlier versions of Mozilla

Although Mozilla has been fixed for 1.7a this patch will fix the problem when
installing current versions of Chatzilla on earlier versions of Mozilla.
Assignee: rginda → neil.parkwaycc.co.uk
Status: REOPENED → ASSIGNED
(Assignee)

Updated

15 years ago
Attachment #140804 - Flags: review?(silver)

Comment 7

15 years ago
Comment on attachment 140804 [details] [diff] [review]
Fix chatzilla for earlier versions of Mozilla

Looks fine, and works in my test Mozilla 1.5.
Attachment #140804 - Flags: review?(silver) → review+
(Assignee)

Comment 8

15 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
Product: Core → Other Applications

Updated

13 years ago
Attachment #118754 - Flags: review?(hyatt)
You need to log in before you can comment on or make changes to this bug.