[LAYER] dogfood - Markup of w3 must be fixed to not use layers on Nav5

VERIFIED INVALID

Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED INVALID
19 years ago
3 years ago

People

(Reporter: Akkana Peck, Assigned: asa)

Tracking

Details

(Whiteboard: [PDT-], URL)

(Reporter)

Description

19 years ago
In the linux viewer, load: http://w3.mcom.com

The display is hosed -- there's what appears to be a text field on top of the
title, a black rectangle of similar but slightly smaller size somewhere nearby,
and scrolling is a mess (scroll down and you get to a blank screen where nothing
is drawn).

Actually it's somewhat hosed on win32 as well, but not nearly as much.

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P1 → P2

Comment 1

19 years ago
Changed priority: P1 is reserved for crashers.

Comment 2

19 years ago
Is the "doesn't do layers" part of this bug a content problem
where the page doesn't recognize the viewer as being capable?

Some of the problems on the this page also look similar to
http://cvs-mirror.mozilla.org/webtools/bugzilla/show_bug.cgi?id=2091
where the links are not active...  Is this a dup?
(Reporter)

Comment 3

19 years ago
Turns out that page no longer shows a text field; I think it was previously
redirecting to http://w3.mcom.com/w3content/w3liteindex.html, which does have a
couple of text fields.  But those are drawn in the right place now.  However,
now the Linux viewer has a button (labelled Netscape something -- can't read the
whole thing because it's hidden under the right text field) drawn underneath and
between the two text fields; the Windows viewer, and 4.5, do not show this
button.

Updated

19 years ago
Summary: [PP] layout of w3 hosed -- linux doesn't do layers? → Layout of w3 hosed -- linux doesn't do layers?

Comment 4

19 years ago
This bug focuses on a small rendering problem on which we are considering
graceful degradation of layers.  Not a [PP] bug...taking off [PP] list.

Comment 5

19 years ago
Note that complete support for 4.x Layers and the Layer DOM is on the "Out" list
for NGLayout 1.0. Use CSS2 instead.

What should work:
LAYER tag and these attributes: left, top, bgcolor, background

What shouldn't work:
Layer DOM in JavaScript, Layer tag attribute "src" (used for transclusion)

Migration path:
Use CSS2 for absolute positioning
Use CSS Object Model for dynamic changes to that positioning
Use OBJECT tag with type=text/html or IFRAME for transcusion

Comment 6

19 years ago
Setting all current Open/Normal to M4.

Comment 7

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
Assignee: kipp → vidur
Status: ASSIGNED → NEW

Comment 8

19 years ago
The w3liteindex page looks fine with todays viewer; the layer issue is still
open for the primary w3 page so I'm reassigning to vidur until the final final
final layer issue is resolved. And I changed the url back to what it was
before...

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: Layout of w3 hosed -- linux doesn't do layers? → [LAYER]:Layout of w3 hosed -- linux doesn't do layers?

Comment 9

19 years ago
Tossing this on the pile of document.layers bugs. It ain't just Linux.

Updated

19 years ago
Summary: [LAYER]:Layout of w3 hosed -- linux doesn't do layers? → [PP][LAYER]:Layout of w3 hosed -- linux doesn't do layers?

Updated

19 years ago
Target Milestone: M6 → M9

Updated

19 years ago
Assignee: vidur → ekrock
Status: ASSIGNED → NEW

Comment 10

19 years ago
Assigning all layers bugs to ekrock.
Blocks: 8023
Status: NEW → ASSIGNED
Target Milestone: M9 → M10
Setting to M10.  See also #8389, related report on http://w3/.
Target Milestone: M10 → M11
Setting to M11 pending final outcome of discussion on n.p.m.layout.
Target Milestone: M11 → M12
Moving to M12. This is an "IS infrastructure must upgrade to be DOGFOOD" issue
now.
Summary: [PP][LAYER]:Layout of w3 hosed -- linux doesn't do layers? → [LAYER] Markup of w3 must be fixed to not use layers on Nav5

Updated

18 years ago
Summary: [LAYER] Markup of w3 must be fixed to not use layers on Nav5 → [LAYER] dogfood - Markup of w3 must be fixed to not use layers on Nav5

Comment 14

18 years ago
erik, are you on IS to make this happen for dogfood?
who is the IS contact that can change the page?

Updated

18 years ago
Whiteboard: [PDT-]

Comment 15

18 years ago
w3 is going away...marking PDT-...ekrock, maybe you could help get IS to pull
this down?

Comment 16

18 years ago
*** Bug 20299 has been marked as a duplicate of this bug. ***
The IS contact is dianaf@netscape.com.  I have notified her and her team and
checked status a couple of times. The last we emailed, they had not assigned an
engineer to do the fix or set a date for completion, but they are aware of the
need and our 12/15 dogfood target.

Updated

18 years ago
Target Milestone: M12 → M13
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Notified IS. INVALID. LAYER, ILAYER, document.layers[] not supported in
Gecko/Nav5. Closed.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 19

18 years ago
Marking verified invalid per last comments.
Moving all [LAYER] bugs to Evangelism component for tracking and open-source
evangelism by mozilla community members of sites that need to upgrade to support 
web standards such as HTML 4.0 (instead of LAYER/ILAYER) and the W3C DOM
(instead of Nav4 document.layers[] or IE document.all()). Sites should be
lobbied to do the upgrade using the email templates that are linked to from
http://www.mozilla.org/newlayout/bugathon.html#layerbugs . When a site's owner
has confirmed receipt of the message requesting an upgrade, the bug should be
marked with the keyword evangelized to indicate that evangelism for that bug is
complete. When the site finishes the upgrade and supports standards, the bug
should be closed.
Assignee: ekrock → nobody
Status: VERIFIED → NEW
Component: Layout → Evangelism
Keywords: evangwanted
QA Contact: petersen → nobody
Target Milestone: M13 → ---
Closing all Evangelism bugs where no evangelism is needed because page has been 
fixed, site is internal to Netscape, report is a DUP, or bug report is no longer 
appropriate for evangelism for any other reason.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago

Comment 22

18 years ago
SPAM:Changing QA contact on 111 evang bugs as I am now the new QA contact for 
this component.

Sorry about the spam

zach
QA Contact: nobody → zach

Comment 23

18 years ago
Reassigning Evangelism bugs to me, the component's new owner.  I would like to 
take this opportunity to thank nobody@mozilla.org for all of his dedication, 
contributions, and hard work, and wish him luck at his new job.  Thanks, nobody.
Assignee: nobody → BlakeR1234
Status: RESOLVED → NEW

Comment 24

18 years ago
workaround bugzilla problem that caused a bunch of evangelism bugs to be 
NEW/INVALID, NEW/FIXED, NEW/WORKSFORME or NEW/DUPLICATE
Resolution: INVALID → ---
(Assignee)

Comment 25

18 years ago
*** Bug 54761 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
What do we do with these, move to Derivatives/netscape 6 to get it moved 
to bugscape?

Comment 27

18 years ago
I have no idea what to do with this.  How can I evangelize the designers of 
pages behind the firewall? Sending to Browser-General for lack of a better idea.
Assignee: blakeross → asa
Component: Evangelism → Browser-General
Priority: P2 → P3
QA Contact: zach → doronr
(Assignee)

Comment 28

18 years ago
I suspect this is a wontfix since they build the new w3 (you should be
redirected if you're using mozilla).

Comment 29

18 years ago
I would expect the folks building w3 would be inclined not to use layers, as N6 
will become the defacto browser that accesses their content. 
anyone know who actaully owns that page? we need to bug them (with a club in our
hands)
(Assignee)

Comment 31

18 years ago
This is not a bug.  The page redirects to a Mozilla compliant W3.  Resolving as
Invalid.  If anyone has problems with this new site the login is pretty simple.
 it takes you to a Netcenter login.  Enter a netcenter username and password
then in the resulting dialog enter the group name "mozilla" (no quotes) and
you're in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
The browser sniffer will redirect you to a custom "My Netscape" page BUT that
page does not contain all the information that is available on
http://w3.mcom.com. If you want to access the information on Netscape's w3 you
are required to use NN 4.x. This is stupid, and this should be fixed. But the
comments state this has been evangelized and something has been done so I guess
we will just have to wait and see...

This is Netscape's internal website so external people need not worry about this.
Keywords: evangelized

Updated

17 years ago
Keywords: evangwanted

Updated

17 years ago
Keywords: evangelized

Comment 33

16 years ago
.
Component: Browser-General → US General
Product: Browser → Tech Evangelism
QA Contact: doron → emeyer
Version: other → unspecified

Comment 34

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.