Cookie permissions inverted

VERIFIED DUPLICATE of bug 198829

Status

()

Core
Networking: Cookies
--
major
VERIFIED DUPLICATE of bug 198829
15 years ago
15 years ago

People

(Reporter: Nahor, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030323
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030323

The cookies permissions get sometimes inverted. 

Reproducible: Sometimes

Steps to Reproduce:
1.Restart Mozilla
2.Open the cookie manager. Note the permissions for some of the cookies.
3.Block or unblock cookies for one website (any should do).
4.Restart Mozilla.
5.Open the cookie manager again. Note that all cookier permissions have been
inverted.
Actual Results:  
All cookie permissions inverted.

Expected Results:  
Except for the website where one was when (un)blocking cookier, no permissions
should have been changed.

As soon as one changes the cookie permissions, the cookperm.txt file gets all
its values inverted. The permissions in the browser stay the same until the
browser is restarted. So there is obviously an inversion in the function saving
the permissions.

Comment 1

15 years ago
wonder if this is related to/fixed by the patch for bug 198829

Comment 2

15 years ago
I would doubt it.  He is using build 20030323.  I tried a new build today at
someone's house for just a minute.  One thing I noticed is that Block or Unblock
are showing at the same time.  This is wrong in the first place.  This has been
present the last couple builds or so.

Comment 3

15 years ago
I'm sorry, this is just for Images that it says Block or Unblock on the context
menu.  I misread.

Comment 4

15 years ago
This is certainly not a blocker.
Severity: blocker → major
This should be fixed by the checkin for bug 198829. It might not be in the
nightly used to report this bug, so please try a new nightly (20030324) when
available.

About the context menu: that would be an other bug. Feel free to file one if you
think the current behaviour is a bug.

*** This bug has been marked as a duplicate of 198829 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
Nahor: please VERIFY or REOPEN after testing the recommended build (or later).
QA Contact: tever → cookieqa
(Reporter)

Comment 7

15 years ago
Yes, it is fixed now.

And for the record, the bug was with nightly I used to report (20030323)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.