Blocking cookies does not remain persistent

RESOLVED FIXED

Status

()

--
blocker
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: mark.slater, Assigned: mvl)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030322
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030322

Visiting the URL while having the option "Ask me before storing cookies" checked
pops up a confirmation dialog for a couple of cookies. Checking the "Use my
choice for all cookies from this site" does not seem to have any effect,
reloading the page will result in the same cookie confirmation dialog.

This not only happens on that page but all pages that try to set cookies.

Reproducible: Always

Steps to Reproduce:
1. Visit site w/ "Ask me before storing cookies" option enabled in prefs
2. Deny cookies
3. Reload page

Actual Results:  
Cookie confirmation dialog came up again, altho I already stated I wanted to
block cookies from the site.

Expected Results:  
Not show cookie confirmation dialog, as I already blocked them for the site.

This has only showed up in very recent builds, eg. this week's nightlies AFAIK
seeing the same with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a)
Gecko/20030322

Comment 2

16 years ago
Same here on Linux rv:1.4a 2003032222.

Also possibly related; in the cookie manager all sites which in 1.3 could set
cookies have been switched to "site cannot set cookies" and vice versa. It seems
that the logic has been negated some where.
(Reporter)

Updated

16 years ago
OS: Windows 98 → All
(Assignee)

Comment 3

16 years ago
This is caused by the checkin for bug 191380. Over to me. Patch coming up.
Assignee: darin → mvl
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
Created attachment 118193 [details] [diff] [review]
Fix fallouts

Permissions were added wron to the list when using the checkbox. Also reading
in was reversed. The header of the dialog was wrong too, and showed the host
part of the cookie, not the actual host (so could show .domain.com instead if
www.domain.com)
(Assignee)

Updated

16 years ago
Attachment #118193 - Flags: review?(dwitte)

Comment 5

16 years ago
Comment on attachment 118193 [details] [diff] [review]
Fix fallouts

while you're in there, 10 points for fixing s/tekst/text/ in
http://lxr.mozilla.org/seamonkey/source/extensions/cookie/resources/content/coo
kieAcceptDialog.js#121.

r=dwitte with that addition
Attachment #118193 - Flags: review?(dwitte) → review+

Comment 6

16 years ago
upgrading severity...
Severity: normal → blocker
(Assignee)

Comment 7

16 years ago
Created attachment 118198 [details] [diff] [review]
updated comment

Comment 8

16 years ago
Comment on attachment 118193 [details] [diff] [review]
Fix fallouts

sorry for the workload we're feeding you, alecf... ;)
Attachment #118193 - Flags: superreview?(alecf)

Comment 9

16 years ago
FYI, eBay not allowing logins from this bug.

Must...spend...money...can't...resist...

Comment 10

16 years ago
Using Build 2003032222 on Linux, I couldn't login any more to www.ebay.de and
meine.deutsche-bank.de. Even reverting to Mozilla 1.3 didn't help.

I checked which sites were allowed to set cookies and all sites were set to "not
allowed to set cookies".

After deleting these entries and deleting all ebay.de cookies, login was
possible again.
Comment on attachment 118198 [details] [diff] [review]
updated comment

sr=dmose
Attachment #118198 - Flags: superreview+
Checking in extensions/cookie/nsCookiePermission.cpp;
/cvsroot/mozilla/extensions/cookie/nsCookiePermission.cpp,v  <-- 
nsCookiePermission.cpp
new revision: 1.2; previous revision: 1.1
done
Checking in extensions/cookie/nsPermissionManager.cpp;
/cvsroot/mozilla/extensions/cookie/nsPermissionManager.cpp,v  <-- 
nsPermissionManager.cpp
new revision: 1.20; previous revision: 1.19
done
Checking in extensions/cookie/resources/content/cookieAcceptDialog.js;
/cvsroot/mozilla/extensions/cookie/resources/content/cookieAcceptDialog.js,v 
<--  cookieAcceptDialog.js
new revision: 1.8; previous revision: 1.7
done
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Comment on attachment 118193 [details] [diff] [review]
Fix fallouts

cancelling sr request, dmose did it already
Attachment #118193 - Flags: superreview?(alecf)
(Assignee)

Comment 14

16 years ago
*** Bug 198906 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
Stll can't login to ebay with 2003032404 win32 build.
(Assignee)

Comment 16

16 years ago
Are you sure it is this bug that caused it?
Can you check the cookie manager, sites tab for any entries for ebay, and delete
them?

Comment 17

16 years ago
No sites listed, still can't login to eBay says browser doesn't have cookies
enabled whenthe setting allows all cookies.
(Reporter)

Comment 18

16 years ago
Just created new eBay account with 2003032404 (win32, Win98SE). Login works.

Lohphat: Try deleting all cookies, make sure you're not blocking anything with
"ebay" in the domain name (I had to allow bugs from various subdomains,
something like signin.ebay.com etc.), and maybe start with a new profile.

Comment 19

16 years ago
I had all kinda of problems with my bank, ebay, yahoo, etc with cookies over the
weekend with builds from the past few days at home. Using 2003032404 at office
now and things seem ok. Hope that will fix my home version too.
(Assignee)

Comment 20

16 years ago
eBay not working might be bug 198870
(Assignee)

Comment 21

16 years ago
*** Bug 198957 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
Pruging cookie list fixed eBay, but now having problems with PSoft8 at work.  

Comment 23

16 years ago
This is a real mess now. No cookies for me seem to be being remembered when I
deny them. http://fileforum.betanews.com/ continually asks for my permission.
Every new tab that opens has about 7 denies for the same cookies. I was using
the build from 3/19 and didn't have this problem. After loading the 3/24 build,
I am having this problem. 

I deleted my previous cookies for this site and still no help. The only thing I
haven't done is a complete cookie purge. I would prefer to not do that unless
someone is 100% certain that will fix this issue. Else, I am going back to 3/19.

Keep up the good work.

Comment 24

16 years ago
*** Bug 198945 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 25

16 years ago
*** Bug 199460 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.