missing option that Mozilla always accepts session cookies

RESOLVED DUPLICATE of bug 53354

Status

()

Core
Networking: Cookies
P5
enhancement
RESOLVED DUPLICATE of bug 53354
15 years ago
15 years ago

People

(Reporter: Marc, Assigned: Darin Fisher)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

One option is missing in Mozilla. IE is having this very usefull option. I want
to be asked for every cookie a website tries to create on my pc. But not for
session cookies. Session cookies should be always accepted.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 53354 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
I think you can do this already with
user_pref("network.cookie.enableForCurrentSessionOnly", true);
(if you does not know how to use this, see
<http://www.geocities.com/pratiksolanki/howto.html>)

Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

15 years ago
AFAIK
user_pref("network.cookie.enableForCurrentSessionOnly", true);
sets all cookies only for this session. If session is closed,
all cookies will be deleted. I want to keep my cookies. I
want to accept and keep or deny cookies for each site I want.
But I want to always accept session cookies.

Marc

Comment 4

15 years ago
If you can describe how this request behaves differently than the duplicate
request, please do so, and REOPEN this bug. It sounds somewhat different to me,
but I would like to hear more details.
(Reporter)

Comment 5

15 years ago
Ok. I will try to explain what I meant.

There are 2 "types" of cookies.
    #1: cookie is only valid for this session (session cookie) and will be
deleted after closing all Mozilla windows.
    #2: cookie will be stored for x days.

Cookie type #1 is handles like #2

Type #2:
I can set the following options for this type of cookies.
 - accept all
 - deny all
 - ask me

If I accept all cookies, everything is ok. But if you select
deny all or set the option to ask for every cookie, there should
be another option:
   [x] accept all session cookies
If I set Mozilla to ask for every cookie, and a website wants to
set a cookie which expires after this session, the cookie should
be accepted automatically.

Marc
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

15 years ago
Dupe of bug 64336, bug 96861, bug 195389 and bug 196316, all duped to bug 53354.

Comment 7

15 years ago
Sounds like bug 196316 to me. 
If that one is correctly duped to bug 53354 then this one should be as well. My
two cts.
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P5
Target Milestone: --- → Future
(Assignee)

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 53354 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.