mail with attachment which is itself mail containing HTML does not display(Win) or attach correctly (Win and Linux) -- nested MIME problem?

VERIFIED DUPLICATE of bug 199995

Status

--
major
VERIFIED DUPLICATE of bug 199995
16 years ago
10 years ago

People

(Reporter: gerth, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Now with SpamAssassin 2.5, it encapsulates the original spam as an attachment so
that it can be cleanly analyzed or forwarded to a place like spamcop.

However, if the spam is itself a multipart/mime containing HTML Mozilla
seems to get lost in two ways:
  a)it doesn't display the HTML in the attachment
  b)if the attachment is forwarded, the headers of 
     the imbedded email are mangled or discarded

This doesn't seem to happen if the original e-mail had no internal
structure of its own.  

I will attach examples.

Reproducible: Always

Steps to Reproduce:
1. receive mail with an attachment of e-mail containing HTML
2. open a compose window to send mail to yourself
3. drag the attachment on to the new message
4. send it
5. open the new mail
Actual Results:  
the attachment has been mangled and lost the headers of
the original e-mail

Expected Results:  
The attachment sent should be identical to the one received

Searching backward, I've found I can make this happen at least as
far back as Mozilla 1.1

It's now an issue because spamassassin used to decorate the spam
but now it encapsulates the original e-mail as an attachment.

This error strips the critical header information needed to
track the spammer making Mozilla behave like old versions of
Outlook --- gack!
(Reporter)

Comment 1

16 years ago
Created attachment 118357 [details]
sample spamassassin encapsulation of spam with html 

This demonstrates the complaint in the bug tha Mozilla
won't display or drag'n'drop the attachment correctly.
For display, it only shows the headers.  For drag'n'drop
it deletes them.
(Reporter)

Comment 2

16 years ago
Created attachment 118358 [details]
spamassassin encapsulted email with no html

This spam is correctly displayed and forwarded
(Reporter)

Comment 3

16 years ago
Created attachment 118359 [details]
email with mangled attachment

The received e-mail with 118357 (sample spamassassin encapsulation of spam with
html) showing that the attachment has been mangled
(Reporter)

Comment 4

16 years ago
First, I apologize for the sleazy content of the attachments in the
testcases. These are real spams tagged by SpamAssassin.

Interestingly, with respect to Comment #1, if you open this link
it only displays the attachment's headers not the full body whereas
the correct display is done for the link in Commnent #2
(Reporter)

Comment 5

16 years ago
I've had a chance to do some more experiments with this and
have found that the incorrect display is apparenetly limited
to Windows, but that the error with attaching is also
found on Linux.

I'm attaching two files from Moz 1.3 on Linux showing 
the attach problem there.

I'm also seeing a bug with attaching plain messages, but this
is under Windows only and I'll create a separate bug for that.
OS: Windows 2000 → All
Summary: mail with attachment which is itself mail containing HTML does not display of forward correctly -- nested MIME problem? → mail with attachment which is itself mail containing HTML does not display(Win) or attach correctly (Win and Linux) -- nested MIME problem?
(Reporter)

Comment 6

16 years ago
Created attachment 118954 [details]
Sample spamassassin encapsulation of spam with html from Linux

This is the base from which next mail was created
(Reporter)

Comment 7

16 years ago
Created attachment 118956 [details]
linux mangled attachment of 118954

This is what was received on Linux after
drag'n'drop of the attachment in 118954
to a new message. The errors are complex
as parts of the attachment were dropped
but also parts of the original were included.
It's not clear what's going on here.
(Reporter)

Comment 8

16 years ago
With respect to Comment #4 about display, the incorrect display
occurs only on Windows...Linux gets it right.

One should note that the display in Navigator is dependent
on how Mail/News View option is set...i.e. Display attachments inline
must be set if you want Navigator to show them..looks like Navigator
uses Mail/News to render e-mail.  

Comment 9

16 years ago
John Gerth: I believe this problem is no longer present in 1.4b.  See also bug 
189058.
(Reporter)

Comment 10

16 years ago
Yes, part (a) (no HTML display) is fixed in 1.4b
Part(b) (mangled header when forwarding) is independent
of whether the attachment has html or not I will
close the bug as a dup of that problem (bug 199995)

*** This bug has been marked as a duplicate of 199995 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 11

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.