Cannot type into form. Keyboard seems disabled

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Girino Vey!, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b; MultiZilla v1.3.1.0) Gecko/20030210

The keyboard does not work properly in this page:

https://home.citidirect-br.citibank.com/citidirect/servlet/SvCtIndex

This page is supposed to provide a virtual keyboard so you do not type your
passowrd directly. But the virtual keyboard is only for the Password field (in
Brazilian portuguese called "Senha"). The other fields should be write enabled,
and should be filled with the bank data of the user (card name).
I am not being able to type into any of the text fields.

Reproducible: Always

Steps to Reproduce:
1. Access the page
https://home.citidirect-br.citibank.com/citidirect/servlet/SvCtIndex
2. try to type into any fields


Actual Results:  
nothing :)

Expected Results:  
text typed should have apeared into the text boxes, esxcept for the "senha" text
box, which should not be accessible (an error popup message should display if
typing into this field).

Comment 1

15 years ago
Yup, I can't get it to work at all.  No virtual keyboard, no text going in!

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030324

Comment 2

15 years ago
I see it too on Linux 2003032305.

Comment 3

15 years ago
I see it too, but you can TAB into the creditcard field if you selected an
option from the dropdown list. 

If this is Mozilla's bug and not poor coding than it should not be component
Browser=general but Form controls I think.

Comment 4

14 years ago
Hello. Can any of you reproduce this bug with Citibank Brasil in a recent
Mozilla build? I just went there using the 20030924 build and was able to
successfully use the virtual keyboard, as well as fill in the other fields that
the keyboard does not apply to. It looks like either Mozilla or Citibank fixed
the problem. Thank you for any new information.

Comment 5

14 years ago
Current nightlies are crashing on this URL, see bug 225696 for details about
browsers used.

I could place a cursor in the field I want to, but typing always went into the
'Senha' field, characters replaced by stars, as it is a password field.
I saved the page using File->SavePageAs (Webpage, complete) 
Looking at the files saved, I found in file wait.htm a function which maybe
causes this permanent focus on Senha:

        function mudaUsuario(obj)
         { 
           var aux = obj.cookie.options[obj.cookie.selectedIndex].value;
           if ( aux != "Login_Citicard")
           {
              obj.Citicard1.value = "xxxx";
              obj.Citicard2.value = "xxxx";
              obj.Citicard3.value = "xxxx";
              obj.Citicard4.value = aux.slice(0,aux.indexOf("|"));
              obj.Senha.value = "";
              obj.Senha.focus();
           }
           else
           {
              obj.Citicard1.value = "";
              obj.Citicard2.value = "";
              obj.Citicard3.value = "";
              obj.Citicard4.value = "";
              obj.Senha.value = "";
              obj.Citicard1.focus();
           }
         }


And I found a file context.htm.
Is this URL a production URL for regular customer use, or just a demo url for
customers, or debugging URL?

<html><head><title>Citibank Online</title>

<script language="JavaScript">
<!--
function SetarFirstAcess()
{
   document.formulario.action="/citidirect/servlet/SvCtContext";
   document.formulario.submit();
}
// -->
</script></head>
<body>
<form method="post" name="formulario" target="ArContextDirect">
<input type="hidden" name="BugNetscape" value="0">
</form>
</body></html>

Comment 6

14 years ago
I get about the same behaviour in MSIE6 as in
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031217

The "citicard" field is obviously only for numbers, which I can type in
directly, without problems (although in Mozilla, the Delete key doesn't work there).

So... I'm not sure if this really is a bug.

Comment 7

14 years ago
Now that the crashing bug is fixed I can properly test this, and it seems to
work now. Closing as worksforme, but feel free to reopen if it does not work in
a recent build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.