Citibank Brasil page crashes Mozilla [@ JavaObject_getPropertyById ]

RESOLVED DUPLICATE of bug 225423

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 225423
15 years ago
7 years ago

People

(Reporter: Jon Henry, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031107 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031107 Firebird/0.7+

Simply navigating to this site and waiting for the Java applet to load will
crash recent nightlies of Mozilla. It's supposed to be a "virtual keyboard" for
inputting your password, I guess the idea was to ensure keyloggers can't be
employed to steal it. No extensions, classic theme.

Unfortunately, I cannot provide a talkback ID for this at the moment. It seems
to be a fairly recent regression, because in the build I have from 10/28 the
site loads, but in the 11/07/03 Firebird nightly and the Tinderbox build from
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/tinderbox-builds/2003-11-12-09/ it
crashes (neither of these builds includes talkback).

Reproducible: Always

Steps to Reproduce:
1. Navigate to the above URL.
Actual Results:  
Mozilla crashes.

Expected Results:  
Display the "virtual keyboard" applet.

I found this site while investigating bug 199105, I've never used the site
before and you shouldn't need a Citibank account (I don't have one). The
installed version of Java is 1.4.2_02. Putting this in Browser-General because
without a stack it's anyone's guess who crashed.

Comment 1

15 years ago
confirming crash with Mozilla BuildID 2003111309, Java 1.4.2_02, Win98

now wanted to test with a talkback enabled build, so I used BuildID 2003100804.

Page was very slow loading,as before, then got a page, as before: 
Bemvenido City bank
Por favor aguarde enquanto o serviço de comunicação segura do Citibank Online
está sendo carregado

and there was some clock spinning long time while some Java was loaded.
Java console shows: 
CERT OK
*000005FFF

The newer browser then gave me a crash after some time loading, this one shows:

Desculpe, mas ocorreu uma falha de acesso em nossos sistemas. Por favor, tente
novamente. Caso necessário, efetue uma nova conexão.

Cannot contact ServletRunner

Comment 2

15 years ago
just retested, with LiveHTTPheaders installed, Sun Java 1.4.2_02, Win98, SP1
Installed 2003102804 into a new folder, but use same profile.
Mozilla BuildID 2003102804 loads fine, first page tells something like Welcome
and wait for something to be loaded, then the second page gets loaded and rendered,
at the bottom of the page a form, and I can see its elements loaded looking at
LiveHTTPHeaders, and rendered, then a last gif, and a virtual keyboard is
displayed. 

Mozilla BuildID 2003111309 crashes reproducably, loads fine until the form is
rendered, but crashes before the virtual keyboard is rendered.
DocWatson comes up and tells about a crash in JS3250.DLL
Three logs are telling the same: Crash in JS3250.DLL .text+0x46d7

Comment 3

15 years ago
A local copy of the page displays the same in BuildIDs 2003102804 and 2003111309,
the virtual keyboard however is replaced by an empty area, in both browsers, no
crash.
Netscape 4.79 is working fine on the real URL, right-click working.
Rightclick not working with Mozilla.

Comment 4

15 years ago
crash Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031114

Mozilla BuildID 2003111415 crashes reproducably, loads fine until the form is
rendered, but crashes before the virtual keyboard is rendered.
DocWatson: Crash in JS3250.DLL .text+0x46d7
Build doesn´t contain Talkback, and last build containing talkback doen´t crash.

Setting keyword Regression, but can´t test further, as there were no windows
build available between BuildID 2003102804 and BuildID 2003111309.
Keywords: regression

Comment 5

15 years ago
regressed between working BuildID 2003110115 and crashing BuildID 2003110619

wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031030
crashed on inofficial build BuildID 2003110619
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031106

Comment 6

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031106 Firebird/0.7+
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031114 Firebird/0.7+

Keywords: crash
Need to get stack traces attached to this bug.

/be

Comment 8

15 years ago
I crash with the same stack shown in DrWatson as in bug 225423, bug 225423
comment 5 seems to mention the regression window 11/03 to 11/04. 

*** This bug has been marked as a duplicate of 225423 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Citibank Brasil page crashes Mozilla → Citibank Brasil page crashes Mozilla [@ JavaObject_getPropertyById ]

Comment 9

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031125
Tinderbox BuildID 2003112523, after bug 225423 was fixed
Product: Browser → Seamonkey
Crash Signature: [@ JavaObject_getPropertyById ]
You need to log in before you can comment on or make changes to this bug.