IMAP subfolders do not display, but do show up in subscribe list.

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Greg Miller, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

IMAP subfolders do not display, but do show up in subscribe list.  Only the
first level of a folder hierarchy shows up in the list on the left-hand pane. 
When creating a hierarchy, the subfolders show up until the folder list is
refreshed.    

Reproducible: Always

Steps to Reproduce:
1.Create IMAP Account.
2.Create folder list, then create subfolders under some of the folders.
3.Refresh the folder list.

Actual Results:  
Did not show subfolders in the left-hand pane.

Expected Results:  
Should have displayed subfolders in the left-hand pane.

Running standard configuration as downloaded.  In Advanced Mail Server
Properties, I have the box unchecked that states "Show only subscribed folders".
 Every folder in this account is subscribed,

Updated

15 years ago
Blocks: 201332

Comment 1

15 years ago
This occurs on Win98 also. The .mailboxlist gets updated, however
never seems to refresh the folder list in the mail client.

Comment 2

15 years ago
The .mailboxlist appears to be cached in panacea.dat under each
user's profile.
(Assignee)

Comment 3

15 years ago
no,  there's no code that iterates over the contents of panacea.dat. What is
cached is the expand/collapse state of parent folders, and if, when we start up,
a folder is already expanded, we won't try to list its sub-children. Try
collapsing all your folders, and shutting down, then re-starting. You should see
all the sub-folders. This is just a work-around - I'm not suggesting there's not
a bug. That should be obvious, but some people have not thought it so :-(
(Assignee)

Comment 4

15 years ago
accepting. Can you attach an imap protocol log? thx.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

15 years ago
I have a similar problem which I think is related. I am using Courier IMAP with
moz release 1.4.

I am not sure if my problem is complicated by the way I am accessing the
Courier. Courier places all folders as subfolders of the INBOX, so by default
they appear as sub folders when the Mozilla IMAP config is default. I have
changed the config such that the Server Directory is "INBOX.", the namespaces
are blank and the server cannot reset them. This results in the correct view
that I want to have of the folders. The only problem that occurs is that the
first connection to Courier makes an IMAP request (not the forward slash):

  list "" "INBOX./%"

which result in the correct subfolder list being returned. When I collapse and
expand the server view, Mozilla makes the IMAP request (no forward slash in this
one):

  list "" "INBOX.%"

which results in the list of children. This is reproducable and the steps
required to reproduce are:

  attach: andy_view1.gif
  % quit mozilla mail
  % start mozilla mail
  attach: andy_view2.gif
  % click Inbox
  andy_imaptrace1.txt
  attach: andy_view3.gif
  % collapse server view
  attach: andy_view4.gif
  % expand server view
  attach: andy_imaptrace2.txt
  attach: andy_view5.gif

Comment 6

15 years ago
I have mistakenly added the attachments to the wrong bug. They are mistakenly
under bug http://bugzilla.mozilla.org/show_bug.cgi?id=209022 which is not
AFAIK related to this bug.

Please refer to the attachments there.

Sorry,

Andy
(Assignee)

Comment 7

15 years ago
Andrew, can you try 1.5b and see if some of these problems are fixed for you?

Comment 8

15 years ago
Tested. Works ok in 1.5b.

Please not mine is not an IMAP expert view. I am just observing.

The traces shows two varieties, still, which seems odd. The first trace is when
Mozilla starts up and shows the initial view of the folder tree. Note line 6
which shows "INBOX.%/%". In the second trace which is due to collapsing and
expanding the folder tree, line 6 shows "INBOX.%.%".

 1. 3 list "" "INBOX.%"
 2. * LIST (\HasNoChildren) "." "INBOX.Templates"
 3. * LIST (\HasNoChildren) "." "INBOX.Drafts"
 4. * LIST (\HasNoChildren) "." "INBOX.Sent"
 5. 3 OK LIST completed
 6. 4 list "" "INBOX.%/%"
 7. 4 OK LIST completed
 8. 4 list "" "INBOX"
 9. * LIST (\Marked \HasChildren) "." "INBOX"
10. 5 OK LIST completed


 1. 2 list "" "INBOX.%"
 2. * LIST (\HasNoChildren) "." "INBOX.Templates"
 3. * LIST (\HasNoChildren) "." "INBOX.Drafts"
 4. * LIST (\HasNoChildren) "." "INBOX.Sent"
 5. 2 OK LIST completed
 6. 3 list "" "INBOX.%.%"
 7. 3 OK LIST completed
 8. 4 list "" "INBOX"
 9. * LIST (\Marked \HasChildren) "." "INBOX"
10. 4 OK LIST completed

(Assignee)

Comment 9

15 years ago
ok, thx, Andrew, I'm going to mark this WFM. I agree that the LIST INBOX.%/% is
wrong, and I'll look into it, but it sounds like this bug is fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

15 years ago
OK, Andrew, I can reproduce the incorrect LIST. I'll try to fix it, but there's
a workaround that you can try - allow the server to override/set the namespaces.
Setting the server directory will still work (doing both those things together
didn't work before, but it should be fine in 1.5b).

Comment 11

15 years ago
The workaround "allowing the server to override/set the namespaces" worked fine
and the LIST is then correct in the two cases. THX.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.