Don't show "Close Tab" contextual menu item (and certain others) on Tab Bar

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: kguru, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030326
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030326

If you right click to the right of your open tabs, the menu option "Close Tab"
closes the tabs, even though you have not clicked on it.

Reproducible: Always

Steps to Reproduce:
1.Right click to the right of open tabs
2.Choose "Close Tab"
3.

Actual Results:  
All of the tabs are closed, and only one tab remains.

Expected Results:  
Since no tab was selected (to the right of the tabs is whitespace), the menu
should not have the choice to "Close Tab"

Comment 1

15 years ago
Confirmed using FizzillaMach/2003032609. The Tab Bar contextual menu should not
show "Close Tab," "Close Other Tabs" (this could be "Close All Tabs" in this
context), or "Reload Tabs."
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: right clicking to the right of tabs close tab menu error → Don't show "Close Tab" contextual menu item (and certain others) on Tab Bar

Comment 2

15 years ago
Why would you want to turn such a useful option off? other browsers (such as
Safari) waste precious screen real estate with close-button widgets on *each*
tab. Mozilla, on the other hand, provides the same functionality through the
context menu. In my opinion, this is exactly what makes Mozilla's tab
implementation so much better, especially in operating systems where the user
can right-hold (not right-click) a tab -> choose "Close Tab" -> release the
right mouse button to close the tab. 

Let's keep things the way they are (quick and logical).

Prog.

Comment 3

15 years ago
prognathous@hotmail.com, this bug is about the Tab *Bar's* contextual menu, not
individual tabs.

Comment 4

15 years ago
Oops... now that I read the summary again, I see what you mean.

Well, in that case, I can confirm that I see this bug on WinXP/20030312, so it
would probably be safe to mark it for all platforms and all operating systems.

Prog.

Comment 5

15 years ago
Marking All/All per comment 4.
OS: MacOS X → All
Hardware: Macintosh → All

Comment 6

14 years ago
Yes, clicking 'close tab' should not close *multiple* tabs!

This bug seems to be fixed; can't reproduce in 1.4 on XP:
Steps to Reproduce:
1.Right click to the right of 3 open tabs
2.Choose "Close Tab"

Actual Results:  
Just the currently displayed tab is closed, and other 2 remain.  

(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624)

Note: Also works fine on X and * parts of tab bar.

Comment 7

13 years ago
*** Bug 281772 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
*** Bug 289270 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
*** Bug 300547 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser

Comment 10

8 years ago
(In reply to comment #6)
> This bug seems to be fixed; can't reproduce in 1.4 on XP:

Also in SM2. Close Tab from Tab Bars context menu acts now the same as the Close Tab button on the far right.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 11

8 years ago
This is easily reproduced, and I think that the original reporter was misunderstood.  Please read the initial comments again.  The problem is that the Close Tab options appear not if you click on a tab - but if you click on an empty portion of the tab bar itself - to the right of any existing tab.  You aren't clicking on any tab at all, just the tab bar, but the context menu still shows the options.  Which he doesn't want to see.  He ONLY wants the options to appear if he clicks on an existing tab.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

8 years ago
Status: REOPENED → NEW

Comment 12

8 years ago
Oops!  I misunderstood too.  He was complaining not just about the empty tab bar space, but also the fact that Close Tab closed all tabs, not just the current one.  I guess that's sufficient.

Comment 1 and comment 3 are actually talking about something else (which led to my confusion).  I'm going to re-resolve.  Greg - if you want to have no context menus at all (for any type of close) on the empty tab bar you're going to have to file a separate bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME

Comment 13

8 years ago
(In reply to comment #12)
> Greg - if you want to have no context menus at all (for any type of close)
> on the empty tab bar you're going to have to file a separate bug.

We can simply reopen bug 281772 (for SeaMonkey) and/or bug 289270 (for Firefox) in this case. They aren't duplicates if this bug is about closing all tabs.
You need to log in before you can comment on or make changes to this bug.