[bugday] Sidebar splitter disengages from sidebar top and bottom borders during resize

VERIFIED DUPLICATE of bug 18991

Status

()

P3
normal
VERIFIED DUPLICATE of bug 18991
19 years ago
19 years ago

People

(Reporter: chrisn, Assigned: eric)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When you resize the sidebar, the splitter that you drag disengages from the top
and bottom borders of the sidebar. If you shrink the width of the sidebar, the
top of the splitter moves _under_ the top border of the sidebar, and the bottom
of the splitter moves _over_ the bottom border of the sidebar.

My solution: you drag a ghost of the splitter, not the splitter itself. When
you're done dragging, and release the mouse button, the actual splitter moves to
the proper location. This would solve the issue completely.
(Reporter)

Updated

19 years ago
Summary: Sidebar splitter disengages from sidebar top and bottom borders during resize → [bugday] Sidebar splitter disengages from sidebar top and bottom borders during resize

Updated

19 years ago
Assignee: trudelle → evaughan

Comment 1

19 years ago
reassigning to evaughan

Comment 2

19 years ago
I seem to remember another bug that addressed the same problem,
but it isn't jumping out at me searching the "Sidebar" component bugs.

On the other hand, this bug report seems to be the converse of bug 15396
"Splitter shows box to soon when dragged to expand", ASSIGNED M15 - in that
case, the sidebar jumps open to its previous width immediately, and the
splitter is obviously disengaged until it is moved out the same distance,
with the same visual defects reported here.

FWIW, sometime in the M10->M11 era, I am sure that the splitter was ghosting
when moved for over a week's worth of builds.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 3

19 years ago
This happens because iframes have widgets and NOTHING can move over them but
another widget. This will be fixed when the docs shell work is done and widgets
are removed.
(Assignee)

Comment 4

19 years ago
*** Bug 15549 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

19 years ago

*** This bug has been marked as a duplicate of 18991 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.