New folder should be created inside the current folder

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
16 years ago
9 years ago

People

(Reporter: janv, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I believe it should also work for new separators this way.
(Reporter)

Updated

16 years ago
Target Milestone: --- → mozilla1.4beta

Comment 1

16 years ago
Insertion in the folder was the first implementation I've done in phoenix (bug
175404).
But doing so one could not insert between two folders and if insertion do not
occur where it's intended (instead: bottom of folder)
I think we should keep it as it is now, except for the bookmark root.
Thoughts?
Blocks: 203660
Status: NEW → ASSIGNED

Updated

16 years ago
No longer blocks: 203660

Comment 2

16 years ago
s/if insertion/insertion

Updated

16 years ago
Blocks: 203660

Updated

16 years ago
Keywords: nsbeta1
(Reporter)

Comment 3

16 years ago
what about adding a checkbox indicating if the user wants to create it inside
the current folder (checked by default) ?

Comment 4

16 years ago
I think such a pref is not desiderable. We have to make a UI decision here.
We may do what ns4.x does here for paste:
- if the folder is closed: insert after it
- if open insert inside it at index=0
For the bookmark root: always insert at index=0

Such implementation has the advantage of always showing the pasted resources.

Note that inserting at index=0 or at the end as we currently do for DND is not
the problem here, but it's so related I could fix it at the same time.
(at the end paste and dnd should be consistent)

Comment 5

16 years ago
s/=0/=1
(Reporter)

Comment 6

16 years ago
ok, I like that approach, do you have time to implement it for 1.4 ?

Comment 7

16 years ago
I'll send my thesis to the referees on wednesday. Then I'll have time to fix
that and the paste issue (I have no seamonkey tree atm)
I guess it will fit with the 1.4 schedule.
(Reporter)

Comment 8

16 years ago
great, sounds good

Comment 9

16 years ago
*** Bug 203394 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 11

16 years ago
After giving some thoughts, I think that inserting resources at the beginning
instead of appending them is a UI change that may irritate users.
Jag, as xpfe owner, you're the one that has to decide.

I attach a fix to the issues that are somewhat independent in bug 210196.
Target Milestone: mozilla1.4beta → ---
If I open the context menu over a free area and select "New folder" the new
folder should be appended at the end of the list - like it's now working.
Instead creating a new folder by first selecting a folder in the folder pane the
new one has to be added as a subfolder. It's a behavior which occurs in almost
all applications. Additional it's really annoying to move the new folder
manually to a subfolder afterwards.
Product: Browser → Seamonkey

Comment 13

13 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody
Status: ASSIGNED → NEW

Comment 14

9 years ago
Current behaviour is fine. WONTFIX
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.