Closed Bug 200150 Opened 17 years ago Closed 9 years ago

Unable to display IDN URL in the attachment pane with Send Page

Categories

(SeaMonkey :: MailNews: Composition, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marina, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: intl, Whiteboard: [patchlove] [adt3])

Attachments

(2 files)

seen with 2003033003 build on WinXP EN

to reproduce:
- Edit your prefs.js file with these lines:
user_pref("network.IDN_prefix", "bq--");
user_pref("network.IDN_testbed", true);
user_pref("network.enableIDN", true);

- go to File|Send page;
//note: the display of IDN is garbled, screen shot to follow
reassign to nhotta
Assignee: smontagu → nhotta
Keywords: intl, nsbeta1
i18n triage team: nsbeta1+/adt3
Keywords: nsbeta1nsbeta1+
Whiteboard: [adt3]
Blocks: IDN
We need to do something here
http://lxr.mozilla.org/seamonkey/source/mailnews/compose/src/nsMsgCompose.cpp#3611


Assignee: nhottanscp → jshin
nsIMsgAttachment has a data member |string url|. Obviously, it can't handle an
URL whose hostname part is in UTF-8. 
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: PC → All
Either change that |string| to |AUTF8String| or pass |nsIURI| or call
GetAsciiSpec and pass that through the |string| parameter.
I still need to fix nsUTF8ConverterService and/or nsSubTextURI. With this
incomplete fix, http://IDN.host.addres.tld works but if there's a path part in
non-UTF-8 charset, it wouldn't work.
(In reply to comment #6)
> Either change that |string| to |AUTF8String| or pass |nsIURI| or call
> GetAsciiSpec and pass that through the |string| parameter.

Ooops. I didn't read this until I made a patch. Passing |nsIURI| may (or may not
) be the best. I'll think more about it. 
bug 229548 and bug 240300 are related to this bug in that both have to call
nsSubTextURI
sorry for spamming. 

s/nsSubTextURI/nsTextToSubURI or nsUTF8ConverterService/
+  if (Substring(scheme, 0, 5).EqualsASCII("http:"))


EqualsLiteral? or maybe even LowerCaseEqualsLiteral?

(personally I'd prefer passing nsIURI instead of a string, since that doesn't
loose the origin charset)
Product: MailNews → Core
Adding a URL for testing.
(from: <http://www.w3.org/International/tests/sec-idn-1>)

With this URL in Seamonkey 1.5, on my Win2K/en-US installation, after Send Page, the attachment panel shows a blank name (the URL's first character is Chinese).  I had wondered if the IDN work done in early 2005 might have affected this bug, but I guess not.

I don't know whether the 'prefix' or 'testbed' preferences (comment 0) are still valid.
Summary: Unable to display IDN in the attachment when sending page → Unable to display IDN URL in the attachment pane with Send Page
Product: Core → MailNews Core
This is a SeaMonkey only bug now (although parts may affect core). Firefox/Thunderbird integrated can Send Link and that works fine, they don't have Send Page afaik.
Assignee: jshin1987 → nobody
Status: ASSIGNED → NEW
Component: Internationalization → MailNews: Composition
Product: MailNews Core → SeaMonkey
QA Contact: marina → mailnews-composition
Version: Trunk → unspecified
Whiteboard: [adt3] → [patchlove] [adt3]
Version: unspecified → Trunk
Duplicate of this bug: 161156
Duplicate of this bug: 74050
WORKSFORME => Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1pre) Gecko/20110408 Firefox/4.0.1pre SeaMonkey/2.1pre

Tested with several example links from http://idn.icann.org/
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.