easy way to start a download from a known URL or list of URLs

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
16 years ago
9 years ago

People

(Reporter: bohm, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

When the Download Manager starts a download, most times it works fine. But I
miss a easy way to start a download from a known URL or from a list of URLs
(ASCII-file) like the program "wget" can do it.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
I think, Bug 142798 is related.

Comment 2

16 years ago
Dupe of 191094?
(Reporter)

Comment 3

16 years ago
It's more than the issue of Bug 191094.
My idea is to add the ability to download files from different URL-sources. Such
URL-sources may be for instance:
1. Direct input from the user
2. Click on a link in current browser page 
3. A arbitrarily HTML-page itself. (local file or internet. Download all links
at this page)
4. Recursive download (spider) of a HTML-page. (usefull for offline reading)
5. A URL from clipboard
6. A list of URLs from a (text-) file

I think, this list may expanded, but at first the Dowload Manager has to get a
open interface for URL-sources in any way.

Comment 4

16 years ago
Adding dependency
Status: UNCONFIRMED → NEW
Depends on: 191094
Ever confirmed: true

Comment 5

15 years ago
related to bug 67178?

Comment 6

14 years ago
*** Bug 265488 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 245344 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
(In reply to comment #7)
> *** Bug 245344 has been marked as a duplicate of this bug. ***

this Bug has 3 other ideas, that are not in the list above (comment #3)
Product: Browser → Seamonkey

Comment 9

12 years ago
Why not use wget?

Having a web browser handle downloads as well as surfing always stroke me as odd. There are download managers for that. I mean, the browser could execute some command to notify the download manager of a new URL to be downloaded, sure. But other than that, I even find the existing functionality extraneous...

Comment 10

12 years ago
@comment #3:

1.+5. this would be same as Bug 191094, in most cases simply enter the url into address bar

These are not really necessary IMHO / or already possible:

2. = Right click, Save Link As ... (already possible)
3.+4. use httrack (or similar) for this!
6. use a download manager!


What i would like instead is:

* mark some text on the webpage and DO something with all marked links,
for example: download the link targets (this is Bug 245344 (closed))
Assignee: bross2 → download-manager
QA Contact: chrispetersen

Comment 11

9 years ago
The SeaMonkey team has no intention of doing this in main UI, but feel free to develop and add-on for SeaMonkey 2 that does this!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.