[@ nsCSSSelector::ToString]

RESOLVED DUPLICATE of bug 200890

Status

()

Core
DOM: CSS Object Model
--
critical
RESOLVED DUPLICATE of bug 200890
15 years ago
15 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
Incident ID 18846409
Stack Signature 	nsCSSSelector::ToString 60e00f5c
Product ID 	MozillaTrunk
Build ID 	2003032608
Platform 	Win32
Operating System 	Windows NT 5.0 build 2195
Module 	gklayout.dll
Trigger Reason 	Access violation
Source File Name 
c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleRule.cpp
Trigger Line No. 	630
Stack Trace 	

nsCSSSelector::ToString
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleRule.cpp, line 630]
CSSStyleRuleImpl::GetSelectorText
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleRule.cpp, line 2268]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2025]
XPC_WN_GetterSetter
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1325]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 845]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 936]
js_InternalGetOrSet [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 962]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2552]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2663]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 861]
nsXPCWrappedJSClass::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1334]
nsXPCWrappedJS::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 429]
PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 119]
SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 147]
nsTreeBodyFrame::PaintText
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 2822]
nsTreeBodyFrame::PaintCell
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 2608]
nsTreeBodyFrame::PaintRow
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 2423]
nsTreeBodyFrame::Paint
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 2206]
PresShell::Paint
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 5815]
nsView::Paint [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 283]
nsViewManager::RenderDisplayListElement
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1249]
nsViewManager::RenderViews
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1198]
nsViewManager::Refresh [c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp,
line 790]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1796]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1154]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1176]
nsWindow::OnPaint [c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp,
line 5236]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3929]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1438]
USER32.dll + 0x3eb0 (0x77e13eb0)
USER32.dll + 0x591b (0x77e1591b)
USER32.dll + 0x595d (0x77e1595d)
ntdll.dll + 0x1fb83 (0x77f9fb83)
USER32.dll + 0x3f0f (0x77e13f0f)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 480]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1287]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1645]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1666]
WinMainCRTStartup()
KERNEL32.DLL + 0x7903 (0x77e87903)

--
I believe i triggered this by deleting a css rule with dom inspector.

i was looking at a page with images off and for some reason the page's links at
the top were color on same background color.

if i'm right the page was from home.ease.lsoft.com, the rule was
body a {color:rgb(0,0,0)}, and i deleted it from object-css style rules.

aSheet->GetNameSpace(*getter_AddRefs(sheetNS));
my guess is that aSheet was null, but i haven't looked at the surrounding code
(Reporter)

Comment 1

15 years ago
bah, i crashed while i was submitting this bug report so i didn't know i
submitted it.

*** This bug has been marked as a duplicate of 200890 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsCSSSelector::ToString]
You need to log in before you can comment on or make changes to this bug.