wrong encoding in xul directory tree (xul directory viewer)

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: glutexo, Assigned: janv)

Tracking

({intl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030405
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030405

When Mozilla is switched to display list of local files as XUL trees, the
files/folders containing non-english characters are shown incorrect(looks like
UTF-8) and are inaccessible. Files and folders named using only by characters,
which are not in the set charset are not shown at all.

Reproducible: Always

Steps to Reproduce:

Updated

15 years ago
Severity: critical → major

Comment 1

15 years ago
*** Bug 221188 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
I have yet to check, but it may well  be specific to WIndows (as filed). In that
case, it's not an xp issue but could well be fixed with my patch for bug 162361
(see also http://www.mozilla.org/releases/mozilla1.5rc2/known-issues-int.html :
the last pargraph in the section 'General'). 

Glutexo and Eyal, what are the default system locale of your Windows XP? What
were file names you had trouble with in the directory tree? If you want to
provide filenames in your bugzilla comment, please make sure that you set
Character Coding (View | Character Coding) to UTF-8 before typing your comment. 
Keywords: intl

Comment 4

15 years ago
Quoting my XP 'Regional Settings' dialog:

Standards and Formats: Hebrew
Location: Israel
Language for Non-Unicode Programs: Hebrew


some of the filenames in my screenshot:

על ה-FTAA.txt
גליאנו, אדוארדו - פרדוקסים.txt
ביכלר, שמשון וניצן, יהונתן - לא בועה, הונאה.doc

hoping bugzilla won't choke on that...

Comment 5

15 years ago
Thanks for your prompt reply. It's strange that Hebrew characters under Hebrew
locale got mangled. I don't have any trouble with Korean characters in the
directory tree view under Korean locale (Win2k English version, but I changed
the default system locale to Korean). I need to play with some other
combinations to be sure what's going on. 

Comment 6

15 years ago
*** Bug 195595 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

15 years ago
Linux build is also reproducible.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030929

Comment 9

15 years ago
Hardware / OS -> All per comment 8.
OS: Windows XP → All
Hardware: PC → All

Comment 10

15 years ago
My comment #5 has to be ignored. I was looking at html view. Somehow I couldn't
switch to xul view. Selecting xul view in Edit|Pref|Debug|Networking doesn't
make any difference at all (in 2003100404). I'll try other builds.
(Reporter)

Comment 11

15 years ago
My XP Regional and Language settings:

Country: Czech Republic
Region: Czech
Encoding for non-U. apps: Czech (cp1250)

Filenames that I have problems with:
(filenames with only cp1250 chars:)

Přezdívka.png
Otevřené
Čeština.txt

(filenames with non-cp1250 chars:)
となりのトトロ.sub
人狼.srt

Comment 12

15 years ago
page source's encoding is Shift_JIS.

--- page source 
<?xml version="1.0" encoding="Shift_JIS"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
---

but, xul directory tree's encoding is UTF-8.
if changed encoding UTF-8 to Shift_JIS, displaied error message.

--- error message
XML Parsing Error: syntax error
Location: file:///d|/downloads/
Line Number 1, Column 1:
---

2004042909-trunk/WinXP-JA

Comment 13

15 years ago
*** Bug 242340 has been marked as a duplicate of this bug. ***
Summary: wrong encoding in xul directory tree → wrong encoding in xul directory tree (xul directory viewer)

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: shrir → xptoolkit.widgets

Comment 14

9 years ago
WFM on SeaMonkey/20100120-trunk/WinXP-JA

Comment 15

9 years ago
Yes, me too.
Marking worksfome.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.