Screen doesn't redraw when switching between tabs or program tasks.

RESOLVED DUPLICATE of bug 204374

Status

defect
RESOLVED DUPLICATE of bug 204374
16 years ago
15 years ago

People

(Reporter: roy, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

Frequently the browser doesn't redraw the screen when switching between browser
tabs or program tasks. The program bar will indicate the browser is selected,
but the rest of the screen still shows the previous tab/program. Mousing over
buttons and menus will restore those, but the browser content window won't
update. It doesn't seem to be specific to certain programs or web pages.


Reproducible: Sometimes

Steps to Reproduce:
1.Keep switching between browser tabs, or between programs.
2.
3.

Actual Results:  
Browser window stops updating.

Expected Results:  
Updated the browser window.

This has happenned with every version of Mozilla I have used(from 1.1 - 1.3).
This doesn't ever happen with IE.

Comment 1

16 years ago
What video card are you using?  Does updating the video drivers help?

Comment 2

16 years ago
Try downloading a more current build and see if that helps.  Recent repainting
issues have been addressed.

Comment 3

16 years ago
Actually, I take my last comment back.  Given that you've seen this from 1.1, I
don't think it could possibly be the recent repainting issue.

Comment 4

16 years ago
Does this happen immediately after launching mozilla (when not using
quicklaunch/"-turbo"-switch)? Then wait for other comments, please.
Otherwise:
If you're experiencing this after browsing for a while, try this:

Open "Settings"-"Advanced"-"Cache".
Limit the browser-cache to 8192KB and click "OK"
Shut down Mozilla, if using quicklaunch("-turbo"-switch) please reboot.
Go on surfing as usual and try to reproduce.
What happens?

I had the same behaviour with 1.2 and now 1.3 on W98SE/GF2MX400(nv41.09).
Every time I changed the browser-cache to somewhat higher like 16384KB or
32768KB it took me just surfing a while to stare at pages definitely similiar to
your descriptions. Reloading a page with Shift+Strg+R sometimes did it but
almost just for the next 3-4 pages. Closing Mozilla completely and starting
again opening the same pages showed that webpage-content wasn't the reason.
Since surfing with a cache of 8192KB all works fine.

Comment 5

16 years ago
Also seeing this occasionally, seems to be related to memory consumption since
sometimes closing other programs helps to overcome the situatsion.

Mostly happens with lots of tabs open. I am using win98, not latest drivers for
video card (GeForce256 chip 32MB memory). I am using Mozilla 1.4rc1, but I
remember it happening also for a while. 1.3alpha already did it but it could be
an older issue too.

Sometimes I suspect that running both Trillian and Kazaa causes this. I'll keep
experimenting with it when it happens next time.

Comment 6

16 years ago
I too have occasionally experienced this problem when loading lots of large
images in seperate tabs. After awhile Firebird seems to stop redrawing the
window completely. The only way to force Firebird to redraw that I have found is
to use the scrollbars (mouse scrolling does not work) or to move the window off
the screen and then move it back. Images that are scaled in the window are never
redrawn even if I scroll.

I also had this problem with the .5 milestone and am having it now with the
current nightly build. My videocard is a Geforce 4 MX and I too am running
Trillian. The problem does seem to be related to memory however, because it only
seems to occur when I am opening several large images/documents in seperate tabs
and closing windows/tabs will sometimes resolve the issue.

Comment 7

16 years ago
I'm marking this bug as a duplicate of Bug 204374 by way of Bug 201221.

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.