{inc}incremental reflow problem for percentage-width float inside table

VERIFIED FIXED

Status

()

VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: ygoodman, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

I use the same layout for all my pages yet in mozilla, the blue box which 
contains text randomly changes size.  Sometimes it is so narrow that only a 
word or two fits on a line. If you add items to the shopping cart, the order 
can extend far to the right of the blue box. This does not happen under IE or 
Netscape. To see this, just click menu items to the left at random or view the 
catalog and add items to the shopping cart.

Reproducible: Always

Steps to Reproduce:
1. bring up ygoodman.com
2. click the catalog
3. add items to the cart
4. refresh the cart page or click the credit card order button

Actual Results:  
the blue box becomes narrow and the text extends to the right

Expected Results:  
the blue box is defined as a fixed size and should not change from screen to 
screen
The button is inside a float which is inside a table cell... the table has no
set width.

Looks like clicking the button makes the float become too small (as do the table
cell and table).

A minimal testcase of that page would be nice....
Assignee: asa → float
Component: Browser-General → Layout: Floats
Keywords: qawanted
QA Contact: asa → ian
Created attachment 119859 [details]
testcase

Click the button to see the incremental reflow bug.

Comment 3

16 years ago
I see it on LInux 2003041008 using the Testcase
Bernd, any thoughts?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: text layout with style sheets is wrong in Mozilla. IE and Netscape work fine. → incremental reflow problem for percentage-width float inside table
This (like the table-in-absolutely-positioned-element bugs) is one of the many
things that should go away if we refactor our shrink wrapping.
Whiteboard: [reflow-refactor]
This is basically identical to bug 199206
Depends on: 199206
er, wrong bug.
No longer depends on: 199206

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future

Updated

15 years ago
Keywords: testcase

Updated

14 years ago
Assignee: layout.floats → nobody
Keywords: qawanted
OS: Windows NT → All
Priority: P2 → --
QA Contact: ian → layout.floats
Target Milestone: Future → ---
Summary: incremental reflow problem for percentage-width float inside table → {inc}incremental reflow problem for percentage-width float inside table

Comment 8

13 years ago
Very similar to bug 305301, just that here the width declaration is not honored too... Any bug dependancy?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

fixed by reflow branch landing
Fixed on trunk by reflow branch landing.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Depends on: 300030
Resolution: --- → FIXED
Flags: in-testsuite?
Created attachment 257474 [details] [diff] [review]
Reftests

Note: This patch assumes that the test for bug 185388 was already checked in with respect to reftest.list
Attachment #257474 - Flags: review?(dbaron)
Comment on attachment 257474 [details] [diff] [review]
Reftests

>@@ -67,17 +67,16 @@

Whatever tool you used to generate this patch is broken; the patch is removing 16 lines and adding 17, so these headers need to be reversed.  (Or did you edit by hand?)
Comment on attachment 257474 [details] [diff] [review]
Reftests

Checked in after testing in pre- and post-reflow-branch builds.
Attachment #257474 - Flags: review?(dbaron) → review+
Flags: in-testsuite? → in-testsuite+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.