Some Microsoft generated web sites cause hangs

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: Oliver Kluge, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3) Gecko/20030313

The page http://www.justiz.bayern.de/olgm/wegweiser/allgemein.htm has been
generated with some Microsoft tools and it does not render correctly (image is
not displayed). But even worse, when you switch to another tab and come back to
this tab, it is frozen.

Other pages generated similiar show other defects like missing body text
(example: http://english.aljazeera.net).

Reproducible: Always

Steps to Reproduce:
1. Load URL
2. Look at it, scroll within, scroll back to the top
3. Switch tabs to and fro

Actual Results:  
The first URL (which is the official Munich Inferior Court page) does not
display the image contained. But although the image is not displayed, it is
selectable (right click -> view image shows the image, so the file is not
broken). After some scrolling and switching to other tabs and back this tab
hangs, you cannot scroll anymore, but the tab is closable and a different (or
the same) URL can be loaded in there.

If you load the same URL a second time, the tab somehow becomes immune and does
not hang again (image still missing).

The Al Jazeera page seems to be built with the same Microsoft tools. If you
click on one of the news, only images and headlines are displayed, but body text
is missing.

Expected Results:  
First URL: Image displayed, no hangs.
Second URL: Body text rendered.

I know that this has to do with the pages source codes, and once again Microsoft
may be to blame (validator complains about these URLs). But as these pages come
up in so many places, including official government pages, I feel Mozilla should
be able to render them adequately in quirks mode. As these pages do not have a
DOCTYPE quirks should be active.

I posted the Al Jazeera URL on the newsgroups to find out other people's view on
this issue, but no-one replied, so I post this as a bug, especially after I
found the Inferior Court page causes tabs to hang.
Which newsgroups did you post on?  Certainly not on .layout....  Anyway,
aljazeera is covered by bug 199003

http://www.justiz.bayern.de/olgm/wegweiser/allgemein.htm has the image in a
relatively positioned inline (a span).  That's bug 79315

*** This bug has been marked as a duplicate of 79315 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Due to comment #51 in bug #79315 I am re-opening this bug, but with a slightly
adjusted summary. The missing image is addressed in bug #79315, the Al Jazeera
body text in bug #199003, so these are DUP.

But the hangs caused by URL #1 seem to be an issue of it's own that needs some
fixing, so I reopen this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Some Microsoft generated web sites cause hangs and other problems → Some Microsoft generated web sites cause hangs
OK, the remaining issue is focus....
(Reporter)

Comment 4

15 years ago
Cannot reproduce this behaviour anymore, so I guess with 1.4 b this is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.