Closed Bug 201720 Opened 17 years ago Closed 17 years ago

popup blocking: enable choice between whitelist and blacklist

Categories

(Core :: Preferences: Backend, enhancement)

x86
All
enhancement
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: mike, Assigned: asa)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Between Mozilla 1.3 and 1.4a the behavior of popup blocking changed from
blacklist (block only popups from selected sites) to whitelist (block all popups
except from selected sites). Unfortunately, this change makes this useful
feature almost unusable for me. Would it be possible to allow the user to choose
between blacklist (old) and whitelist (new) behavior?

Reproducible: Always

Steps to Reproduce:
Tip: if you are asking for a pref to configure prefs, you are creating UI bloat. Resolving as INVALID.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
I don't quite understand your point. I am only asking to reconsider dismissing a
very useful feature. There are people who would like blocking popups but cannot
use the way it is done in 1.4a. However there are people who prefer the new way.
What is wrong with letting them choose?
*** Bug 213216 has been marked as a duplicate of this bug. ***
This looks like another case of Mozilla developers telling users what's best for
them, and how they should use their browser, AND I DON'T LIKE IT.

What's wrong with the choice to either use Blacklist or Whitelist?   Reducing UI
bloat is not an excuse for deleting a useful choice of operating behaviors.  The
stupid little icon is not good enough for me!

VOTE FOR THIS BUG! and if you have the nerve to face the wrath of developers who
think they know better than you how to browse the net, REOPEN THIS BUG!
Jim, Bugzilla is not the place for feature advocacy. If you'd like to start an
advocacy discussion in the newsgroups or forums at mozillazine.org, then do so,
but  do not attempt to start some campaign in Bugzilla. Doing so is an abuse of
this system and will not be tolerated. 
Christopher Hoess: I don't see any "pref to configure for prefs" in Michael's
request, so you should explaint your resolution to reporter better.

dveditz, danm, sairuh: I'm sorry to bother you, but you all were involved in
pop-up blocking and I want you opinion on this bug request.

There is idea to support both pop-up whitelisting and blacklisting. It was
INVALIDated by choess, because such feature will require preferences. IMHO in
Firefox exists example of GUI, which can handle such case: In Preferences |
Privacy | Cookies is this UI:

[ ] Accept all cookies           (Exceptions)

Where Exceptions button opens whitelist or blacklist depending on state of
checkbox. Same GUI should be used for popups in Suite:

[ ] Allow pop-up windows         (Exceptions)

I personaly see whitelisting as more useful choice, but it's just my point of
view. Should be Michaels' request with proposed GUI reconsidered as valid? In
other case, you should verify this resolution.
Component: Browser-General → Preferences: Backend
Blacklisting was removed because some people with organisational clout at the
time felt the UI to support both simultaneously was too complex to explain to
average users. They probably had a point. Adam your idea seems to be very simply
to allow only one kind of list at a time, black or white. That's simple enough
in concept. It does get complicated with extant exceptions (allowed or
disallowed sites) when the switch is thrown to the other kind of list and
additional exceptions are added. That was the whole issue, as I recall.

Basic support for blacklisting exists in Mozilla. In theory it could be
re-enabled with some simple front-end tweaks. But any proposal would have to
address the issue I outlined above, as well as additional UI necessary to
support blacklists properly. Originally for example popup windows had a special
button that added the site that opened it to the blacklist and closed the
window. And let's not forget the context menu item.

In the end it's not trivial.

So, what to do. I have no studies to back me up on this, but it seems to me that
whitelists please 98% of Mozilla users. As far as I know, there is no core
Mozilla developer interested in accepting the work of reconstituting popup
blacklists. The idea has been invalidated or won't-fixed several times. There is
a similar bug 202394 in Firefox. But since the Firefox UI is more tightly
controlled and has the stated goal of being small and incomplete, I can almost
guarantee it will never be implemented.

Since the back end support is already there, since core developers are
uninterested, since the idea has already been shot down several times, since
this is a feature the majority of users have no use for, this seems like a
perfect application for a third-party extension.
Dan, thank you for your comment.
You need to log in before you can comment on or make changes to this bug.