Mozilla uses western fonts even though page specifies iso-8859-2

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
16 years ago
3 years ago

People

(Reporter: ignacyn, Assigned: smontagu)

Tracking

(Blocks: 1 bug, {intl, testcase})

Trunk
PowerPC
Mac OS X
intl, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.65 KB, text/html; charset=iso-8859-2
Details
1.54 KB, text/html; charset=iso-8859-2
Details
(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030411
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030411

Set your font preferences like this: 
Western:
Proportional: serif
Serif: Chancery (or any other font that is easy to distinguish)

Central European:
Proportional: serif
Serif: Sand CE (or any other font that is easy to distinguish, but different
from the western one)
Check the box “allow documents to use other fonts”

Now try testcase1:
Besides everything else, what can we observe?

Point 1 when no font is specified by html code:
The lines that do not contain polish signs are displayed using Sand CE; the
lines that do contain polish signs are displayed using Chancery (which was
specified for Western in Preferences) with polish signs looking ok. But, when
you change the western: serif font to Arial, then the lines that contain polish
signs are displayed using Arial(for non-polish signs) and with font glyph
substitution from Lucida Grande(for polish-specific signs)

Points 2,3,4 where font is specified by font-face and appropriate font name:
The parts of the words that are “ordinary” (not-polish specific) signs are
displayed using appropriate font, but polish signs are displayed using Lucida
Grande fallback.

Now try testcase2:

Point 1 when no font is specified by html code:
No difference from testcase1

Points 2,3,4 where font is specified by font-face and appropriate font name:
WOW, everything looks grate 

So, what is the difference?
In testcase1 the font-face tags are general like font “face="Courier New,
Courier, monospace”” In testcase2 the font-face tags are very well specified
like “face=”Courier CE””. It is rather obvious that in real-live nobody will
specify the font using the second method.  Moreover, Mozilla should know that
when page specifies iso-8859-2 as the content it should use CE fonts. Mozilla
uses for example Times instead of Times CE, even though the page specified the
content to be iso-8859-2.

To summarize, this bug consists of two closely related bugs:
1. When fonts are specified by font-face tag: Mozilla uses western fonts and not
CE fonts, even though page specifies to be iso-8859-2
2. When fonts are not specified in any way: Mozilla uses fonts specified in
preferences for CE for text blocks that do not contain iso-8859-2 signs and
Mozilla uses fonts specified for Western in preferences when text block contains
iso-8859-2 signs.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
Created attachment 120341 [details]
Testcase1
(Reporter)

Comment 2

16 years ago
Created attachment 120342 [details]
Testcase2
(Reporter)

Comment 3

16 years ago
Resolving this bug would finally resolve bug 158560 and bug 148361 and would
make bug 163085 not so desperately needed, because fallback will not be used so
often anymore and the same with bug 121540 and bug 165878 and finally it will
make Fizilla display iso-8859-2 characters correctly. That's why I decided to
mark the severity as major. Moreover, I would suggest listing this bug in Meta
bug 103669. (I don't know if I can add this bug over there by myself). On top of
that is my guess, that it is probable that this bug is not only Mac specific. It
may be that on PC Mozilla does the same but fonts on PCs have more characters
included (compare Arial for Mac and Arial on WinXP). Unfortunately, I have no
access to a PC, so I cannot confirm this.
(Reporter)

Updated

16 years ago
Blocks: 158560

Comment 4

16 years ago
As I said in bug 158560, comment 9, bug 165878 may be the underlying cause of this.
Severity: major → normal
Keywords: intl
The Foo CE fonts are not needed on OS X. They are part of the Mac OS 9 world.
The glyphs from the legacy Foo CE fonts have been rolled into the respective
non-CE fonts. That is, on OS X the glyphs that were previously only in Sand CE
are now available in the font called just Sand.
(Reporter)

Comment 6

16 years ago
I don't think bug 165878 is the cause or the duplicate of this bug. Let's
analyze a standard font face tag: font face=Helvetica, Arial, sans-serif. Now
Mozilla uses Helvetica font in every case, even if page is iso-8859-2 and it
should use Helvetica CE. And this is bug 201817 about. Instead, bug 165878 is
about Mozilla looking for other fonts if it cannot find Helvetica in this
example Arial. That's the way I see it. Moreover I see no correlation between
bug 165878 and the issue mentioned in point 2 of my bug report (at the very end
of it), that is, Mozilla uses fonts specified for CE (in preferences) when text
block doesn't contain iso-8859-2 specific characters and Mozilla uses font
specified for Western (in pref) when the text block contains iso-8859-2
characters (See testcase1 or 2) and it all happens in one iso-8859-2 declared
document.
(Reporter)

Comment 7

16 years ago
Actually the all-glyphs-included Sand font came with 9, not with X. Fonts that
are in System(X)>Library>Fonts are unicode and include all the glyphs. Fonts
that also came with X, but are in Library>Fonts are not always unicode.
Moreover, when I deleted all the fonts from my System besides those that are in
System>Library>Fonts, so I only had something like 6 fonts(non of them with CE
ending and all unicide), Mozilla in preference tab "Central European" still
displayed fonts like Times CE and Helvetica CE. On top of that is the fact that
Mozilla still didn't pass the testcases1&2. The first part of test 1 was
displayed using Times (which I have selected in pref), but iso-8859-2 signs were
not smoothed. In testcase 2 even though it specifies Times CE in 3rd part and
this font was not in the system, Mozilla displayed everything clearly and with
good font-smoothing using Times.
So to conclude:
When html does not specify the font type Mozilla uses the font from pref(but the
bug which causes Mozilla to use western font from pref in text blocks that
contain iso-8859-2 still exists). Even though the font is unicode Mozilla
doesn't display the signs correctly. On the other hand when page declares the
font e.g. Times CE and there is no such a font in the system, Mozilla uses Times
(which includes all glyphs) and displayes everything well. In both cases the
page declares to be iso-8859-2. Therefore it seems that in two similar cases
Mozilla behaves differently.
> Mozilla in preference tab "Central European" still
> displayed fonts like Times CE and Helvetica CE. 

Bug 159809.

> The first part of test 1 was displayed using Times (which I have selected 
> in pref), but iso-8859-2 signs were not smoothed. 

Bug 163085.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

15 years ago
Could somebody with sufficient permissions add a 'testcase' keyword,please.

Comment 10

15 years ago
I saw similar reports from Polish people (e.g. iso8859-2) viewing pages with
only a few fonts available or when printing via Xprint where the fonts specified
via CSS/"font face" did not contain all the chars required to render the text.

Maybe platform/OS should be All/All ?

Comment 11

15 years ago
As I understand, this bug is that fonts specified for CE in the font selection
menu are NOT used for ISO-8859-2 encoded pages. Instead, for ISO-8859-2 pages,
fonts specified for Western Europe are used. 

I can't reproduce this on Linux with Xft build so that I suspect this is
Mac-specific. 
I'll upload another test case to help us figure out wherte the problem is.

Keywords: testcase
Can someone check the status of this bug (now that bug 120401 is fixed)?
Depends on: 120401
(Reporter)

Comment 13

14 years ago
I still can confirm this bug :-(, despite the bug 120401 being fixed.
(Assignee)

Updated

11 years ago
Attachment #120341 - Attachment mime type: text/html → text/html; charset=iso-8859-2
(Assignee)

Updated

11 years ago
Attachment #120342 - Attachment mime type: text/html → text/html; charset=iso-8859-2
QA Contact: amyy → i18n
Latin fonts now typically include Western European and Central European glyphs in the same font, so we no longer treat Central European as a distinct font group.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.