All users were logged out of Bugzilla on October 13th, 2018

Location bar: must select all on initial click

VERIFIED DUPLICATE of bug 19217

Status

P3
normal
VERIFIED DUPLICATE of bug 19217
19 years ago
14 years ago

People

(Reporter: warrensomebody, Assigned: radha)

Tracking

Trunk
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you want to select all the text in the location bar and type a new URL right
after a window comes up, the first time you click it ends up just putting the
cursor at the beginning of the line, no matter where you clicked. You then have
to double click to select all the text.

In 4.x, the first click selects all the text.

Updated

19 years ago
Assignee: beppe → kin
Target Milestone: M13

Comment 1

19 years ago
Kin, I think this may be a dup of 18179

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
Accepting bug.

The fact that the first click sets the cursor at the beginnging is a dup of 18179.

I'm not duping this bug because the 4.x SelectAll on Focus/Click feature that
warren describes needs to be added to Gfx Text widgets.

Updated

19 years ago
Assignee: kin → buster
Status: ASSIGNED → NEW

Comment 3

19 years ago
*** Bug 21450 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
The bug has 2 parts:
1) the first click doesn't get passed through to the editor.  This is covered by
other bugs, don't have numbers handy.
2) the browser folks have to put in logic to "select all on initial click",
that's behavior unique to the url bar.  other text controls shouldn't work that
way, it's weird.  I think there's already a bug on that one, too.

Updated

19 years ago
Assignee: buster → leger
Component: Editor → Browser-General
Depends on: 21612

Comment 5

19 years ago
the layout portion of this is covered in bug 21612, which will be fixed by
tomorrow.  Reassigning the browser portion to the browser team.  It may already
be a dup.

Comment 6

19 years ago
cc'ing self and don

Updated

19 years ago
Assignee: leger → radha
Summary: must click 3 times in location bar → Location bar: must select all on initial click

Comment 7

19 years ago
radha?

Comment 8

19 years ago
If "select all text on inital click" is going to make it into the final (I
really hate this feature but a lot of people like it), please don't do it
exactly the same as v4.  v4 requires 3 clicks in the url bar to get it to edit
where you would like (When 2 clicks could do it)

v4.7 does this (If you click fast... if you are slow it works in 2 clicks):
1st click: Selects all (Puts the cursor at the end of the line)
2nd click: >>> Is ignored <<<
3rd click: finally deselects everything and places the cursor where you want it.

Updated

19 years ago
Target Milestone: M13 → M15

Comment 9

19 years ago
Move to M15.  Not required for beta 1.

Updated

19 years ago
Component: Browser-General → Selection
QA Contact: sujay → elig

Comment 10

19 years ago
This is a selection bug; QA Assigning to self, of course.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Component: Selection → Browser-General
Resolution: --- → DUPLICATE

Comment 11

19 years ago
moving back to browser-general, it's not a selection bug.  dup of 19217

*** This bug has been marked as a duplicate of 19217 ***
(Reporter)

Comment 12

19 years ago
a) I don't necessarily think that failure to select all on first click (bug
19217) is the same problem as this (clicks being ignored), but I'm willing to
see if 19217 fixes it.

b) I think this is a real pain in the ass and should certainly be fixed for
beta, if not dogfood.

Comment 13

19 years ago
warren:

please re-read my comment on 1999-12-13 11:48 and see if you agree with the dup.
(Reporter)

Comment 14

19 years ago
Sounds like dups to me.

I'm not sure I agree that the location bar should be different from all the
other text fields though. That's weird.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
I don't agree either, but that is how 4.x behaves...

Verifying as duplicate.

Updated

19 years ago
Depends on: 24762
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.