FTP sometimes downloads less than 10%, then all of a sudden says Finished

VERIFIED DUPLICATE of bug 201663

Status

()

VERIFIED DUPLICATE of bug 201663
16 years ago
16 years ago

People

(Reporter: iamjaime7l, Assigned: asa)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

I tried downloading a 450mb file over some non-public FTP server. I tried a few
times, yet every time when it got around 20-50 mbs (randomly, not at a specific
point in the download), it stopped downloading, said Finished (and wrote
completed 450000/450000 - not the specific number, but that's beside the point).
The source of the stop is doubtedly Mozilla, although it could be, but that's
not the problem. The problem is that Mozilla lists it as finished, while the
file is, in truth, only partially downloaded. For now I'm downloading it with
CoffeeCup FTP, which has a feature that could do good in Mozilla as well - it
continued downloading the file from the 40mb that have already downloaded.

Reproducible: Sometimes

Steps to Reproduce:
1. Find a somewhat unreliable FTP server.
2. Start downloading a big (100mb+) file.
3. Wait until it says Finished, and see if it stops before it should.

Actual Results:  
The Download Manager said Finished while the file was not.

Expected Results:  
It should not have said Finished, but continue or at least say "connection
failed" or something along those lines.

Default theme.

Comment 1

16 years ago
bug 201663 has been fixed lately, could you retry with a current nightlie?

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 201889 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
my bad
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 201663 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
VERIFIED, dupe of fixed bug.
-> ftp.
Try the daily build and reopen if the problem is still occurring...
Status: RESOLVED → VERIFIED
Component: Browser-General → Networking: FTP
QA Contact: asa → benc
You need to log in before you can comment on or make changes to this bug.