Make mozTXTToHTMLConv a full TXT->HTML stream converter

RESOLVED WONTFIX

Status

()

defect
P3
normal
RESOLVED WONTFIX
20 years ago
4 years ago

People

(Reporter: BenB, Unassigned)

Tracking

(Blocks 4 bugs, {helpwanted})

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b2 -

Firefox Tracking Flags

(Not tracked)

Details

Blocks: 20195
Whiteboard: [HELP WANTED]
Blocks: 5351
Blocks: 23953
Keywords: helpwanted
Summary: [HELP WANTED] Create TXT->HTML stream converter → Create TXT->HTML stream converter
Whiteboard: [HELP WANTED]
Currently, mozTXTToHTMLConv only provides a string conversion function
(ScanTXT). The only thing you have to do is to
- convert nsI*Stream to nsString and back
- maybe do simple option handling (wrap PRUint32 whattodo in nsISupports, so
users can pass it through aCtxt, I think).

Ideally, you should pass the data in chunks of paragraphs to ScanTXT, so URL
recognition can work across linebreaks.

REASSIGN to Jud.
Assignee: nobody → valeski
Blocks: 26753
Summary: Create TXT->HTML stream converter → Make mozTXTToHTMLConv a full TXT->HTML stream converter
No longer blocks: 26753
Target Milestone: --- → M18
Component: MIME → Networking
Product: MailNews → Browser
REASSIGNing to myself.
Assignee: valeski → mozilla
Status: NEW → ASSIGNED
Target Milestone: M18 → M19
Target Milestone: M19 → mozilla0.9.1
Changing personal priorities. Giving away most of my bugs :-( (reassigning to
default owner).

I will still track these bugs closely. If you need my input, feel free to ask me.

New owner: Please do *not* close these bugs (as WONTFIX or whatever you may
find) unless they are fixed. Rather, reassign to <nobody@mozilla.org>, if you
don't want to work on them.
Assignee: mozilla → mscott
Status: ASSIGNED → NEW
Blocks: 76732
moving to future milestone. 
Target Milestone: mozilla0.9.1 → Future
Blocks: 116842
mass assignment of text->HTML bugs to MailNews w/ esther as QA.
Component: Networking → Mail Back End
Product: Browser → MailNews
Target Milestone: Future → ---
Version: Trunk → other
*** Bug 227110 has been marked as a duplicate of this bug. ***
-> networking.

Netscape-made compromises don't matter much now, this Necko is where it belongs.
Assignee: mscott → darin
Component: Mail Back End → Networking
Product: MailNews → Browser
QA Contact: lchiang → benc
Blocks: 39042, 171150
Flags: blocking1.8b2?
Flags: blocking1.8b2? → blocking1.8b2-
Assignee: darin → nobody
QA Contact: benc → networking
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.