Closed Bug 2023 Opened 22 years ago Closed 21 years ago

viewer crashes if I start enter a URL while a page is loading

Categories

(Core :: XPCOM, defect, P1, critical)

x86
Windows 95
defect

Tracking

()

VERIFIED DUPLICATE of bug 1596

People

(Reporter: dbaron, Assigned: gagan)

References

()

Details

If I enter a URL while the above page is loading (it has a linked style sheet,
which loads slowly, and I know you just made this loading asynchronous), then
the viewer crashes.

To be more specific, my NGLAYOUT_HOME is set to the above URL, I have
NG_REQUEST_VER=5.0alpha, and I entered the URL
http://www.w3.org/Style/CSS/Test/current/sec5525b.htm right after I started the
viewer.  Then the blue background of the above URL (my home page) came up
(after, I think, when I saw "Connecting to www.w3.org..."), and then the viewer
crashed (GPF, I think, or whatever its called now.??).

I have had the same thing happen twice (with different pages).
I think this is now fixed, but I'm not sure.  I haven't replicated it lately,
and when I reported it it was happening every time.
I take that back.  It still happens, but I think it is *only* with the above
URL.  Sometimes the viewer freezes rather than crashes (GPF?).
Sorry...wrong URL... it now only occurs if the URL I go to is
http://www.fas.harvard.edu/~dbaron/sat/ .
Assignee: rpotts → gagan
Re-assigned to gagan@netscape.com.

Gagan, is this a netlib bug?  Who should get this?
Status: NEW → ASSIGNED
Investigating...
I think this is now just a duplicate of bug 1596, except 1596 was just resolved
as WORKSFORME.  Of course, I don't have a build since last Friday.  I haven't
checked yet today.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Since I reopened bug 1596 today, I'm resolving this as a duplicate of 1596,
which is owned by karnaze@netscape.com

*** This bug has been marked as a duplicate of 1596 ***
Status: RESOLVED → VERIFIED
Marking Verified as a dup.
Moving all threading bugs to XPCOM. See bug 160356.
Component: Threading → XPCOM
You need to log in before you can comment on or make changes to this bug.