Prefill news filter-Delete caused false unread message count in folder pane for msgs deleted

RESOLVED DUPLICATE of bug 311774

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 311774
15 years ago
10 years ago

People

(Reporter: esther, Assigned: Cavin Song)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Using trunk build 20030415 on winxp, macosx and linux and the new prefill filter
for newsgroups using the Default action of Delete, the newsgroup count for
unread messages will include in the number count the deleted messages each time
the user pings the newserver for new messages.  This constant changing of the
unread count will cause confusion for the users especially if no messages are
download when clicking Get Msg. 

1. Launch app that has a newsgroup and mail account.
2. Send a message from a mail account to that newsgroup and get the message.
3. Select the address of sender, right mouse click and select "Create a Filter
from Message" accept the prefill defaults (which includes the action to Delete
the Message).
4. Send 4 more messages to that newsgroup and click get message 

Result:  the 4 messages that are deleted from view will show up in the Folder
pane count Total, Unread columns and paraenthesis if the unread column is not
displayed.
Expected: these message counts should not show up in these columns

Note, if you switch to another newsgroup or mail account and then back to the
newsgroup with the bad counts the counts will revert back to what they should be
until you click Get Msg again.
(Reporter)

Comment 1

15 years ago
nominating since another bug regarding false positive bug counts (bug 64476) was
nominated and fixed AND because this is a new feature with Delete as the default
action (more users will run into this).  
Keywords: nsbeta1
(Reporter)

Comment 2

15 years ago
Note, the msf file for this newsgroup may be the problem, if I remove it and let
it build again, the count is correct.  cd'ing sspitzer 
Assignee: mscott → cavin

Comment 3

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Product: MailNews → Core
Blocks: 71728
Bug 311774, although newer, has more information on it.
No longer blocks: 71728
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311774
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.