Closed Bug 202351 Opened 18 years ago Closed 14 years ago

Devanagari / Hindi / Marathi / Sanskrit text alignment not proper using "text-align: justify;", "word-spacing" or "letter-spacing"

Categories

(Core :: Layout: Text and Fonts, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 240914

People

(Reporter: alkuma, Assigned: prabhat.hegde)

References

()

Details

(Keywords: intl, testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

This is simulatable in Win XP with Indic, Win2K with Indic, Linux RH7.1 with
Indix on Mozilla 1.3
Other examples: 
http://stardataentry.com/hindi_book/home.html (click on the first link on the
left frame)
http://www.indiapress.org/dharma/ (The Hindi text at the bottom)
http://iceprincess.livejournal.com/2002/08/07/ (Devanagari
conversation text)
In case you need more information see  search google groups for
cba03d0.0304132207.783e2176@posting.google.com
Displayes fine on IE6 XP with Indic, IE5 Win2k with Indic.

Reproducible: Always

Steps to Reproduce:
1. Make sure you are able to see devanagari, by following the steps in
http://geocities.com/alkuma/seehindi.html
2. Go thru the thread
http://groups.google.com/groups?dq=&hl=hi&lr=&ie=UTF-8&oe=UTF-8&selm=cba03d0.0304132207.783e2176%40posting.google.com
3. Try http://members.tripod.com/~sunilbhadekar/justify-test.html
 or
http://www.indiapress.org/dharma/
or http://iceprincess.livejournal.com/2002/08/07/
or http://stardataentry.com/hindi_book/home.html
Actual Results:  
Mozilla is trying to "stretch" the words to make the display flush on
both ends, but it's breaking the words in the process, whereas it
should be messing only with the spaces in between.

Expected Results:  
See the juxtaposed screenshots of IE and Mozilla at
http://members.tripod.com/~sunilbhadekar/justify-test.html
Attached file Test Case
I think this bug is best demonstrated using a test case. I am attaching one
here. This test case is an HTML file with two table cells. Within the bottom
one of the cells, the Devanagari is rendered correctly, while in the top one,
the bug is manifested.
And here is a screenshot of what this test case looks like to me.

This bug is present both in Mozilla 1.5 (old, I know, sorry) and Firefox 0.8,
on Windows 2000.
Just installed Mozilla 1.6 and the bug is still present.
Unfortunately, I don't use one of the listed languages, so I can't confirm this
bug, but I did add the intl keyword (and correct a minor typo in the summary) so
hopefully somebody who can confirm will notice it.
Keywords: intl
Summary: Devanagari / Hindi / Marathi / Sanskrit text alignment nor proper on using <div style="text-align: justify;"> → Devanagari / Hindi / Marathi / Sanskrit text alignment not proper using <div style="text-align: justify;">
Confirming.
Keywords: testcase
Depends on: uniscribe
Summary: Devanagari / Hindi / Marathi / Sanskrit text alignment not proper using <div style="text-align: justify;"> → Devanagari / Hindi / Marathi / Sanskrit text alignment not proper using "text-align: justify;", "word-spacing" or "letter-spacing"
*** Bug 280956 has been marked as a duplicate of this bug. ***
Is this only in CTL builds? It is WFM on this Linux trunk build.
Linux trunk build (gtk2+xft) doesn't render Devanagari and other complex scripts
correctly in the first place, whether justified or not. (see bug 215219 and bug
214715)
Aha, ok. Thanks for the pointers!
Status: UNCONFIRMED → NEW
Depends on: 164700
Ever confirmed: true
https://bugzilla.mozilla.org/show_bug.cgi?id=240914

is just the same. Mark this a duplicate of that or the other way round. 

*** This bug has been marked as a duplicate of 240914 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Component: Layout: CTL → Layout: Text
QA Contact: arthit → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.