[regression] labels, junk status, has attachment, should only allow for is/isn't

VERIFIED FIXED in mozilla1.4beta

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
mozilla1.4beta
regression
Bug Flags:
blocking1.4.2 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Trunk build 2003-04-18: Mac 10.1.5
Trunk build 2003-04-16: WinXP

Overview: Mail Views Label criteria does not always produce expected results:

* Label|Contains - opposite effect (Doesn't Contains works as expected)
* Begins With - opposite effect
* Ends With - opposite effect 

Steps to reproduce:
1. In the Views drop down select Customize
2. Select New to open the Customize Message Views dialog
3. Select the New button
4. Enter the following criteria and close the dialog
"Label" "Contains" "Important" 
5. Select a folder with messages without labels and other messages labeled as
important.

Actual Results: Displays all messages, except for the ones labeled Important.

Similar problems occur when using other label criteria:
* Begins With - opposite effect
* Ends With - opposite effect 


Expected Results: Should display only messages labeled Important.
(Reporter)

Updated

15 years ago
QA Contact: esther → nbaca
there was a recent regression, and contains should not be a choice here.

only is / isnt.
Status: NEW → ASSIGNED
Keywords: regression
good catch, I'm working on this regression.
Summary: [mailviews] Customize, Labels|Contains creates unexpected results → [regression] labels, junk status, has attachment, should only allow for is/isn't
*** Bug 202590 has been marked as a duplicate of this bug. ***
*** Bug 202578 has been marked as a duplicate of this bug. ***
*** Bug 202576 has been marked as a duplicate of this bug. ***
I have a strong feeling that this was caused by the checkin for #125197,
specifically the change to mailWidgets.xml

I'm verifying that now...
yes, the change to mailWidgets.xml for bug #125197 was the cause.

trying to now to figure out why that change was necessary, and if there is
another way to do what shuehan was trying to do.
the fix for this will be in bug #202848

the fix was to back out the change to mailWidgets.xml, and then find a fix for
the problem that shuehan was fixing, which I've logged as bug #202848
Depends on: 202848
fixed.

to test that bug #125197 is still ok, do an "any" search on "any name", and then
switch to an "all" search.

it should switch back to the default search for an "all" search, display name.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.4beta
(Reporter)

Comment 10

15 years ago
Trunk build 2003-04-22: Mac 10.1.5
Trunk build 2003-04-24: WinXP, Linux RH 8
Verified Fixed. 

- Labels, Junk Status and Has Attachments now only have two criteria (is,
isn't). - Also checked the steps in comment 9 and switching to an "all" search,
then shows "Display Name".
Status: RESOLVED → VERIFIED

Comment 11

15 years ago
"Has Attachments" does not work for me:
"Attachment Status" is "Has Attachments"

After selecting that, no mail appears.
(With "isn't" all mails appear)

Mails are on an UW IMAP Server.

Also having a rule for the Received Header (there are normally more than one!!!) 
does not work.
(e.g. Received contains pop.myprovider.com)

It looks like that all headers which are not standard header do not work at all.

Any ideas?

Ciao,
Gerhard
Flags: blocking1.4.2+

Comment 12

15 years ago
I forgot: Version is 1.4.1

Ciao,
Gerhard
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.