junk mail filter capabilities should be like other filters

RESOLVED DUPLICATE of bug 198100

Status

enhancement
RESOLVED DUPLICATE of bug 198100
16 years ago
9 years ago

People

(Reporter: martin, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

I'd like to have the same file control/attribute modification abilities
when filing junk emails as i do with regular filtered email.
For instance, I'd like to be able to
move junk email to any filter of my choice.  i know i can give any name
currently, but it seems to
give greater importance to the spam filter by placing it right below
my sent folder, which i find visually distracting when message unread counts
show up.  

 what I'd like to see are the same attribute modification
controls  that are available with ordinary filters.  in particular, what
i personally want to do is automatically mark all the messages as read, so that
the unread counter next to the folder doesn't distract me with non-zero values.

anyways, i want to take this opportunity to say i love mozilla email.  great
work guys!


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
this must've been logged already, but i can't find it.
confirming.

fixing subject to be more concise.
"junk email filter should have similar moving/filing capabilities as regular
filters" -> "junk mail filter capabilities should be like other filters"

i would actually like to see them implemented in the same dialog, 
"junk flag" "is" "set" for the three columns (like "subject" "is" "Free V1AGRA").
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: junk email filter should have similar moving/filing capabilities as regular filters → junk mail filter capabilities should be like other filters

Updated

16 years ago
OS: Linux → All

Comment 2

16 years ago
Bug 181631: add Mark As Junk/Not Junk to list of available filter actions
Bug 196036: add Junk Status to list of criteria
Bug 198100: Option to change precedences of junk control and normal filters

Are there any other specific capabilities desired?

Comment 3

16 years ago
Marking dependencies from comment 2.
Depends on: 181631, 196036, 198100

Comment 4

16 years ago
*** Bug 234661 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
I'd also like to see this. In my case, what I want to do is:

IF ((Mozilla_Bayesian_filter==junk) AND (Header contains "X-Spam-Score: ssss")){
     move to Junk folder
}

I'd like to use both Mozilla's internal Bayesian filtering and Spam Assassin
(provided by the ISP) together to reduce false positives.

Thanks

This is also similar to Bug 220716 and Bug 234044
Product: MailNews → Core

Updated

14 years ago
Blocks: 66425
Assignee: naving → nobody
QA Contact: laurel → filters
Product: Core → MailNews Core

Updated

11 years ago
Duplicate of this bug: 223898
I have now submitted a patch for bug 198100, which allows normal filters to be applied either before (as happens now) or after (which is new) bayes processing. With this feature, you can turn off the "normal" junk processing, and handle this entirely through filters. Or use them in combination, as the new postplugin filter occurs after junk classification, but before the normal junk processing. So the requests of comment 0 or comment 5 are doable.

So I am tempted to just dupe this bug to 198100. The only other option I see is to define this bug as asking that junk default processing be removed entirely and rely entirely on filters, or to take the default processing and implement it through filters exposed to the filter UI. I can't really see the point of either of these however.

Any objections to duping to bug 198100?
Whiteboard: [dupeme]
no objections, so duping
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 198100
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved
Duplicate!
Whiteboard: [dupeme]
You need to log in before you can comment on or make changes to this bug.