[META] Improve mail message filters

RESOLVED WONTFIX

Status

enhancement
RESOLVED WONTFIX
19 years ago
5 years ago

People

(Reporter: netdragon, Unassigned)

Tracking

(Depends on 23 bugs, {helpwanted, meta})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

19 years ago
This bug is a meta for enhancing filters, giving it more options, and improving 
it. Not for anything but enhancements.
Reporter

Updated

19 years ago
Keywords: helpwanted

Comment 2

19 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

19 years ago
QA Contact: esther → laurel

Comment 3

18 years ago
Adding a bunch more bugs:
bug #9416: handle virus/internet hoaxes (see comments in the bug to see why 
this belongs in filters)
bug #11036: filter by example
bug #11037: Javascript filters
bug #16750: "match whole word" filter criterion
bug #16902: filter based on any header (mail)
bug #16913: filter based on any header (news)
bug #73075: NoCeM support (news)
bug #76773: NoCeM-E support (mail)
Depends on: 9416, 11036, 11037, 16750, 16902, 16913, 73075, 76773

Updated

18 years ago
Depends on: 82237

Comment 4

18 years ago
This bug is useless. Why have a tracking bug for general improvements? Just
browse the "Filters" component if you want a list.

Heck, you could even create a "[META] Improve Mozilla META bug" and add all the
bugs we have in the database to it.

Comment 5

18 years ago
reassigning to naving
Assignee: gayatrib → naving

Comment 6

17 years ago
re: comment 4, we have already bug 9417. There's not a point of creating bugs
that will never be closed. 

Comment 7

17 years ago
I propose adding bug 11034 (reply and forward filter actions) and bug 67421
(filtering on body of messages in IMAP accounts selected for offline download).
Reporter

Updated

16 years ago
Depends on: 59365, 197598

Updated

16 years ago
Depends on: 11034, 67421, 80439
No longer depends on: 197598

Comment 8

16 years ago
Replacing duplicate dependencies.
Depends on: 11033, 158032, 162789
No longer depends on: 34340, 60876, 62687, 82237
mass re-assign.
Assignee: naving → sspitzer

Updated

15 years ago
Depends on: 247020

Comment 10

15 years ago
That bug obviously belongs to this META bug -- it could be solved as an
additional filter rule ("email address is valid (not empty) and contained in
addressbook xxx").
Depends on: 202169
bug 105169 
Depends on: 105169

Updated

15 years ago
Depends on: 61635
No longer depends on: 247020
Product: MailNews → Core

Updated

15 years ago
Depends on: 262184
Reporter

Comment 13

15 years ago
Removing bug 61635 because it's marked a dupe of bug 262184.
No longer depends on: 61635

Comment 14

14 years ago
Bug 294632 Filters should be per-Folder, not per-Account

Comment 15

14 years ago
Adding:
bug 11035
bug 11039
bug 34973
bug 168905
bug 198100
bug 200788
bug 202605
bug 223591
bug 260046

And suggesting this bug be renamed '[META] filtering system revamp' - many bugs about the filtering system are not exactly enhancements but rather expectations of a different/more flexible structure of the system.

Also adding
bug 193625

whose fix is a temporary hack and should be replaced by something done via the filtering system.

Updated

13 years ago
Depends on: 330785

Comment 16

13 years ago
No need for the double META, it's confusing.
Summary: [META] Improve filters META bug → [META] Improve mail message filters

Updated

13 years ago
Depends on: 366094

Comment 17

13 years ago
Bug 260046 is about the error console and not about mail message filters, removing dependency.
No longer depends on: 260046
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 19

12 years ago
See the WORKSFORME justification for bug 9417.
Depends on: 294632
Filter on "Nobody_NScomTLD_20080620"
QA Contact: laurel → filters
Product: Core → MailNews Core
Depends on: 419356
Duplicate of this bug: 484405
I have there a little UI-prob ...

... I think the new filters-wiz should focus on the folder the filter is created from ... ???
(Example: A lot of mail-accounts - the wiz focus ever on the first ...)

Is there an bug already filed? Can somebody file a new bug and CC me ???

THX in advance!
Depends on: 531483

Updated

8 years ago
Depends on: 355902

Updated

8 years ago
Depends on: 676852

Updated

8 years ago
Depends on: 74430

Updated

8 years ago
Depends on: 601939
I propose closing this bug.

* we have a filters component. 
* bugzilla and our methods for using bz have improved substantially since this bug was created. 
* and comment 0 proposes this mainly be for ENH bugs

anyone caring so much about so many filter bugs, can change their bugzilla prefs to "watch" the filters@mail.bugs address, and save us all the trouble maintaining a meta bug that literally has almost no focus.
I agree. Choosing WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.