Image resizing triggered by resizing window

VERIFIED DUPLICATE of bug 189982

Status

()

Core
Layout: Images
--
minor
VERIFIED DUPLICATE of bug 189982
15 years ago
14 years ago

People

(Reporter: Ernst de Haan, Assigned: Jim Dunn)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.4a) Gecko/20030422
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.4a) Gecko/20030422

When I view an image that's bigger than the display area, it's resized
automatically. That's fine. When I click on it, image resizing is disabled, and
I see the image with the actual detail and size. That's still okay. Then I
resize the window and the image automaticlly resizes again. That's not okay. It
should remember that I wanted to see the image real-size. In fact, that's the
reason that I resized the window, I wanted to see the complete picture, full
size, full detail.

Reproducible: Always

Steps to Reproduce:
1. Have automatic image resizing enabled
2. View a quite large image
3. Click on the image to disable automatic image resizing
4. Resize the window and see the image resize
Actual Results:  
It resized the image down to fit the new display area size

Expected Results:  
Not scale the image down to fit the new display area size but leave it unscaled.
(Assignee)

Comment 1

15 years ago
hmmm not sure if I would agree with this, it is more a matter of 
preference.  However, I understand that you want some control and
you aren't alone.  I think this is a dup of bug 189982 (which is
being worked on).  If you don't agree that that bug is the same
as yours, please re-open.

*** This bug has been marked as a duplicate of 189982 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Also note that automatic image resizing is disabled by default in Mozilla (the
FreeBSD port might have changed that default, I don't know).

You can change your auto image resizing prefernce in edit/preferences/appearance.

Comment 3

14 years ago
V: dupe.
Status: RESOLVED → VERIFIED
QA Contact: tpreston → benc
You need to log in before you can comment on or make changes to this bug.