fix accessibility on MingW builds

RESOLVED DUPLICATE of bug 815581

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 815581
15 years ago
5 years ago

People

(Reporter: Jonathan Wilson, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Accessibility is currently not working because the MingW w32api libraries
dont have the needed definitions. Once the definitions are in, someone will need
to fix the mozilla code. I believe Accessibility also relies on the Microsoft
Active Template Library (for which a free clone does not yet exist).
(Reporter)

Updated

15 years ago
Blocks: 203303

Comment 1

15 years ago
atlstl.org?
(Reporter)

Comment 2

15 years ago
I checked atlstl.org and pulled down their downloads but it appears that what
they have is something that sits on top of ATL rather than being a replacement
for ATL.
So, that doesnt help.
(Reporter)

Comment 3

15 years ago
This is going to need a copy of the MIDL compiler & the stuff that goes with that.
Also, a copy of ATLBASE.H, ATLCOM.H & WINABLE.H

Comment 4

15 years ago
After some google digging:

It looks like midl is in the platform sdks.

( see
http://search.microsoft.com/default.asp?qu=midl&boolean=ALL&so=RECCNT&p=1&nq=NEW&ig=03&ig=04&i=99&ig=05&i=99&ig=02&i=42&i=43&i=44&i=45&i=46&i=47&i=48&i=49&i=50&i=51&i=52&i=53&i=54&i=55&i=56&i=57&i=58&i=59&i=60&i=61&i=62&i=63&ig=07&i=99&ig=01&i=00&i=01&i=02&i=03&i=04&i=05&i=06&i=07&i=08&i=09&i=10&i=11&i=12&i=13&i=14&i=15&i=16&i=17&i=18&i=19&i=20&i=21&i=22&i=23&i=24&i=25&i=26&i=27&i=28&i=29&i=30&i=31&i=32&i=33&i=34&i=35&i=36&i=37&i=38&i=39&i=40&i=41&i=99&siteid=us/dev
)

From http://www.winehq.com/hypermail/wine-devel/2001/11/0130.html:
" (It is possible to find copies of midl.exe floating on the net,
as some people have put together "COM kits" for Borland C++ that contains
midl.exe and some standard .idl files and put them on the web) ".

So you might find some in that space too.

Comment 5

14 years ago
WINE has a IDL compiler. Should we attempt to get this merged in to mingw so we 
can enable these componets?

Comment 6

11 years ago
Hmm, does the checkin for bug 325070 have any effect on this bug or bug 341965?

Comment 7

11 years ago
Assigning bugs that I'm not actively working on back to nobody; use
SearchForThis as a search term if you want to delete all related bugmail at
once.
Assignee: dmose → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: dsirnapalli → accessibility-apis

Comment 9

7 years ago
Is this bug still valid?

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 815581
You need to log in before you can comment on or make changes to this bug.