SELECT elements honouring invalid attribute WIDTH

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
--
major
VERIFIED WORKSFORME
15 years ago
14 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Ug, I know I'm going to regret this.

I've searched for 'width select', and other assorted combinations in Bugzilla.

Anyways, with build 2003-04-24-12 (trunk, Windows 2000), and the attached
testcase, the selects aren't paying attention to the WIDTH attribute of the SELECT.

This is also visible on http://channels.netscape.com/ns/news/health.jsp (see
'Choose a topic'.
The problem here is related to the presence of the 'width' attribute on the
'select' element in the markup. This is not a valid HTML 4.01 attribute on
a 'select' element **but** apparently gecko honours it setting, in the current
test case, the width of the element to 10 'something' where something is px or %,
I did not test.

This is a bug and we should ignore that width attribute.
Summary: Select's width attribute getting ignored. → SELECT elements honouring invalid attribute WIDTH

Comment 3

15 years ago
I can imagine the stream of bug-reports :-)
Yeah, well.  This is already filed, and even has at least one dup other than
this one.  roc+moz is probably the assignee.  Please find and dup.
Whiteboard: DUPEME

Comment 5

15 years ago
I think it's 201797.  Here, the reporter doesn't acknowledge the WIDTH 
attribute as invalid, so maybe that should be confirmed in that bug :)
Fixed by bug 201797, I believe.

*** This bug has been marked as a duplicate of 201797 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
No, this was not fixed, even with bug 201797 checked into 1.4b.  Testcase still
breaks (note that there's no horiz scrollbar), and the WIDTH attribute is still
honored.  I can't reopen, but I think it should be.
Dang.  You're right.  My testcase is broken, but the site works... they must've
changed their code.  Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 9

15 years ago
*** Bug 205014 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
OK, now the testcase works in build 20030523...did someone fix this?
Robert O'Callahan must've, but I'm not sure the bug #.
wfm
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
verified with build 2004-06-29-08 on Windows XP.
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.