Single vs. double clicking confusion

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: mozilla, Assigned: mpt)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: -- to be discussed in n.p.m.ui)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
In the sidebar, various panels (such as Bookmarks and Related Links) are using
single-clicks to open/close folders and double-clicks to load in URLs into the
content area.

This is so wrong that I don't even know where to start...

We need to standardize on single-clicking to select something and double-clicking
to open/close/load it in.
(Reporter)

Updated

20 years ago
Priority: P3 → P2

Updated

20 years ago
Assignee: slamm → german

Comment 1

20 years ago
Passing to German. Just name how is should be done and I will do it.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
I think it depends. For example in a what's related panel which is read and
click only I would want to a) eliminate folders altogether if possible b)and b
make action 'open folder' single click. This is usage based and consistent with
what we found Moz Classic usability testing for the bookmarks panel. Double
clicks are inherently unaccessible and inconvenient to beginners.
On the other hand in mail where selection matters a lot with regards to a folder
the action sequence you desribe is the proper one.
Ideally the twistie icon "> for closed  V for opened" takes care of single-click
opening in the sidebar but we not have enough space for it. Maybe a twistie only
without a folder for those cases?
(Reporter)

Comment 3

20 years ago
For Related Links, while we can get rid of the top level RL folder if we hang
all the data off of the root of the tree, you still won't be able to get rid of
folders completely as the RL data itself can specify folders internally...
things such as the "Site Info for ..." folder.

Again, I don't agree that the action of opening folders should be single click.
It is very inconsistent to have folders in some parts of the application that
require double-clicking while others do not.

Usability testing from Moz Classic demonstrated that beginning users could grasp
double-clicking... in the worst possible case, they'd try a single click, and if
that didn't work, they'd then try double-clicking.

The big issue here is that some panels (say the bookmarks panel, for example)
are going to REQUIRE double-clicking, as they'll need single-clicks to mean
"select". Why?  As always, the answer:  management.

That's why twisties become very useful to have, as they allow the single-click
to open behavior. I don't buy into the whole argument of "we don't have enough
space for twisties" either, by the way.  :^)

I'm arguing that we need as much of a consistent behavior across the entire
application as possible. Since there will be panels in the sidebar that allow
management (whether we do it or not, 3rd parties will), they're going to need
single vs double click distinctions.  I believe it would be very bad to have one
panel where a single-click does only a selection, while in another panel it
actually loads something in.  That's BAD.

(Have I ranted enough?)

Comment 4

20 years ago
I agree with Robert.

Comment 5

19 years ago
Marking beta1, this came up quite a bit at the sidebar bugorama. Slamm needs to 
be told when you should one click and when you should double click.
Keywords: beta1

Comment 6

19 years ago
Having sat through those usability tests as a specialist, I can tell you that 
German is right in the findings. Additionally, users had no difficulty with the 
difference in behavior for mail and the browser as long as the look assisted in 
determining the behavior. Consistency is not the objective. Understandable, 
usable and enjoyable is. Users associate different interaction behaviors with 
different looks. We should take advantage of this and encourage this where it 
will enhanse the design and usability. We have actual data here that this can 
work. And of course I can test this again in an up comming study.
(Reporter)

Comment 7

19 years ago
I *STRONGLY* suggest that you do some rigorous testing in this area.  

Inconsistent behaviors don't often lead to a user experience which is either 
understandable or enjoyable to most users.

[German is actually WRONG in regards to Mozilla Classic.  (Sorry, German... but 
you told me this yourself!).  Mozilla Classic testing showed that beginning 
users might not initially understand the difference between single and 
double-clicking; however, they would naturally try the latter if the former 
didn't work.]

Comment 8

19 years ago
Oh perhaps I should be more specific. These things need to be taken in context. 
The SideBar that the users were presented with in this study gave little visual 
indication to the user how it was suppoded to be used. For that reason we got 
the response that beginning users had difficulty with the single and double 
click. For example: things that look like links, or buttons, they are associated 
with a single click and in mail the folder is associated with a double click. 
These visulal ques get a far stronger response that consistency across apps. 
Possibly because they are consistent with use metaphores. The response to a 
visul cue can be imediate and very strong. 
(Reporter)

Comment 9

19 years ago
This bug specifically refers to XUL tree listings (such as the Bookmarks or
Related Links sidebar panels, as mentioned in the initial posting of this bug),
not HTML-based sidebar panels;  there are no buttons or items that look like
links in the XUL trees in question.

Updated

19 years ago
Whiteboard: [PDT-]

Comment 10

19 years ago
As Lake points all it all depends on context. In the Moz Classic test we did 
indeed have people see single click and use that once bookmarks were docked to 
the side of the browsing window. In that context people liked the convenience of 
single click. We also found that there was -no- harm when single click was used 
for bookmarks in the sidebar, and at the same time double click was used for 
selectable, manageable items that could be re-arranged. 
In the context of the bookmark popout window people did not like single click 
action when they meant to do selection, and were concerned about 'launching' the 
bookmark when they did not intend to do so. Also s Robert points out most people 
double-clicked once they saw that single click did not do anything but selecting 
the item. I think it all depends on what the search results in the sidebar want 
to be: here is my opinion:
Just becuase technically they are both based on lists things like a mail folder 
and a search results are not the same and will not be used similarly by end 
users.

Search results do not require any management, that is re-arranging or some such 
thing. Therefore we should allow the convenience of single click. I believe that 
we will find once again that that will not conflict with using double click in 
other contexts such as mail, where managing list items is required. I also do not 
think it will kill us if we have double click there, but I would like to see how 
well single click is faring with real users and then make corrections as we need 
to.
In addition I strongly recommend that search items be shown as clickable links 
because that is what they are.
Target Milestone: M16
(Reporter)

Comment 11

19 years ago
Ah ha!  Search results can have a *LOT* done to them! They can have context 
menus brought up on them to do things like filter out bad results, save items 
into bookmarks, dragging&dropping into bookmarks or a browser window, be 
re-sorted based upon different criteria such as relevancy or price, and LOTS 
more.

Don't make the mistake of thinking that there is no management to search 
results.

We need to PLAN for both what we want in 5.0 as well as future versions, and 
build up consistency from the initial get-go, so that the features we add into 
the product remain understand and usable, instead of us being forced to change 
behaviors that users will have built up and come to expect.
(Reporter)

Comment 12

19 years ago
*** Bug 28103 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

19 years ago
Users have coped with clicking doing one thing, right-clicking/Ctrl-clicking 
doing another thing, and dragging doing something else, for several years. They 
haven't needed to select a search result (before doing something to it) before; 
they've just brought up the context menu for the link. Surely the same principle 
could apply to bookmarks and other items which currently need a double-click? 
Single-click to activate, right-/Ctrl-click to alter, drag to move.

(Disclaimer: I have a personal vendetta against the whole idea of double clicks.)

Comment 14

19 years ago
I agree with German and Lake (and the users I've watched); we really need to 
use single-clicking for most of the default 'load this' actions in sidebar. The 
poor guy in today's usability study single clicked every single time, then 
double clicked when nothing happened.  Even Lake, when trying to show him how it 
worked afterward, was single-clicking.  In the past six years we have taught 
users to single-click in the browser, doing so well that it is now an option in 
the major OS file system GUIs. I understand the argument that you can do other 
things to many of these items, including manage them.  However, the overwhelming 
thing they are used for is to load them in the browser window.  We should 
optimize for that case by providing and showing all the same affordances as we 
do for links.
(Reporter)

Comment 15

19 years ago
I'm kind of amazed that we are running these tests without knowing ourselves how 
to use the product. (Single vs. double-clicking)

Updated

19 years ago
Blocks: 28883

Comment 16

19 years ago
A different viewpoint: can we write products without knowing how they will 
really be used?  We don't have a captive user base, we can't insist they learn 
the 'right way'.  Lake "knows" how to use the product, that just shows how 
strong the single-click training is.  
(Reporter)

Comment 17

19 years ago
Nice try, Peter, but no cookie for you.

Comment 18

19 years ago
I know, and I know it well. That is just the point we are making. Even when 
people know, they single click on these and double click when it doesn't work. 
And that is the wording the participants use "When it doesn't work I double 
click" (this is a direct quote) After the study was done I even asked one: Well, 
what about sorting and filtering... They said: you don't want to do that here 
maybe like bookmarks in another window. I have even asked leading questions that 
should get them to ask for double clicking but no dice. There are still some 
more studies to go. I bet you want to wait and see.
(Reporter)

Comment 19

19 years ago
If we want to wait and see (i.e. wait for the usability study to complete), then 
great, but why did German just send out a big email about how the search UI is 
bad with one of the reasons being that everything isn't single-click?

Anyway, I'm certainly happy to wait and see the final results.

As an aside, I really like hearing direct quotes such as:

    "When it doesn't work I double click" (this is a direct quote)

since it helps add validity to the idea that we can have a consist double-
clicking sidebar panel if we choose, and that even beginning users would be able 
to use it.

Comment 20

19 years ago
I think the more important excerpt from that is "it doesn't work".
(Reporter)

Comment 21

19 years ago
Peter, the point is this:  If a user tries one thing (single click) and it 
doesn't work, they do know to try something else (double-clicking) which DOES 
work.

That's a lot different than something which the user can NEVER figure out.

Beginning users may not want/need/understand functionality like sorting, 
selecting multiple items, drag&drop, etc.  Intermediate/Advanced users do... and 
will want this functionality.

If we design our product solely for beginning users, we'll be no better than IE's 
current interface... fine for beginnings, and really annoying for a lot of users 
who aren't immediate beginners.

Comment 22

19 years ago
These are not immediate beginners. We are testing typical/intermediate 
users. Even the novice user had some experience with searching and browsing. 

Comment 23

19 years ago
I think I understand your point pretty well.  Nobody is claiming they'll never 
figure it out, just that it is not expected, and perceived to 'not work'. We 
don't design just for beginning or advanced users, we need to design primarily 
for typical expected users, and the typical cases. So far, data seems to show 
most people expect to click once on these, and don't expect to sort or manage 
them much, if at all. This means that we should optimize for this case.  
Sorting, multiple selection, D&D, etc are all edge cases that should be handled 
without interfering with the typical expected case.  We should certainly 
optimize for advanced users too, after all we hope that all our users stick with 
the product long enough to learn it well.  Even so, they (we?) are a tiny, 
although very vocal, minority.
(Assignee)

Comment 24

19 years ago
Since we're all picking favorite quotes, here's mine: `After the study was done I 
even asked one: Well, what about sorting and filtering ... They said: you don't 
want to do that here maybe like bookmarks in another window.'

Given that users are often poor judges of their own past or future behavior, 
there is no way (unless your usability studies go for weeks on end) that you can 
get accurate figures on how often users will try to manage bookmarks etc in a 
sidebar. But I'd agree with whoever was the subject in this test: if I want to do 
any decent management of my bookmarks, I'll open the bookmarks window, where I 
have more room than there is in the sidebar. (And, where the bookmarks look like 
selectable items, rather than like links.)

> Beginning users may not want/need/understand functionality like sorting,
> selecting multiple items, drag&drop, etc.  Intermediate/Advanced users do...
> and will want this functionality' ...

(a) Intermediate/advanced users are the ones who know how to use context menus,
    and other forms of interaction which are slightly more complex than a single
    click.
(b) If you implement the standard Shift-click and drag-a-box-round-them methods
    of selecting items, you haven't taken away the ability to select items in the
    sidebar.
(c) Making items links doesn't take away drag-and-drop ability.
(d) If you follow that argument to its logical conclusion, we'll have to make
    users double-click to follow HTML links as well, because
    intermediate/advanced users occasionally want to do something else with links
    besides follow them.
(Reporter)

Comment 25

19 years ago
Bookmarks in the sidebar panel currently have icons, toggles, selection, all the 
goodies of old-fashioned trees;  no underlining like links.

Earlier comments in this bug note that we all agree that HTML looking links are 
single-click. No one is arguing that.

While you may not, I very much expect to be able to have management in the 
sidebar panel. I believe we need to strike a careful balance between these 
camps.

Comment 26

19 years ago
All panels do not have to be the same.  Of the 500 panels we ship with beta1, 
about 490 will be web pages from Netcenter - all of which have single click web 
links.

Most of My Sidebar is on the web.  The only way to be 100% consistent is for 
every panel without exception to be single click.  I don't think that is the 
right thing since there may be cases like Bookmarks where double-click is the 
correct answer.

What needs to be consistent is the way we display a single click (underlined) vs 
the way we display double clicks, but different panels can have different 
behaviors.  I don't think we have to limit 100% of our panels to just single 
click.

Here is my recommendation.  We need to decide for each client panel whether it 
should be single click or double click.

If we all agree that each panel needs to have its own decision, let's then start 
specific bugs per panel and  mark this one as Fixed (as it is).

(Marking as Netscape confidential since discussing Netcenter content.  After 
beta1 can make this bug public again.)
Group: netscapeconfidential?

Updated

19 years ago
QA Contact: paulmac → shrir

Comment 27

19 years ago
spam: changing qa contact on sidebar bugs from paulmac to shrir@netscape.com 
(all 67 of them!)

Comment 29

19 years ago
Whoops, wrote bug. Ignore my attachment.

Comment 30

19 years ago
I'd be interested in hearing how JohnG knows the 'the correct answer' for 
bookmarks - do you have the teacher's edition John? BTW, I'm making this bug 
public again based on your b1 comment. FWIW, I've been using Win98 in 
single-click mode now for a couple of weeks.  The main difference for me is 
having to click a _lot_ less. I haven't haven't had any problem managing files, 
although some of the techniques are not very discoverable.  If only Windows 
didn't now also assume that I'm too stupid to be shown file sizes...
Group: netscapeconfidential?
(Assignee)

Comment 31

19 years ago
Ok, so assuming that
(1) panels where single-clicking is the opening action will have items which
    look like links,
(2) panels where double-clicking is the opening action will have items which
    don't look like links,
(3) separate bugs will be filed if any particular panel is using the less useful
    choice of these two behaviors, and
(3) Robert in the red corner seems destined never to agree with German, Lake,
    Peter, and myself in the blue corner ...

... Is this bug just going to ping-pong between Robert and everyone else forever, 
or are we going to get a decision for slamm to actually implement?

Comment 32

19 years ago
Again, if managing items were the *primary* task of a panel, then link appearance 
and single click might not be as well suited as double click. I believe the 
majority will *access* the data in most panels (like bookmarks, whats related, 
search results or most contetn panels) more than anything most of the time, just 
like search results, therefore single click and link appearance are the best 
educated guess we can make.
As far as Netscape 6 is concerned I believe the decision has been locked down. I 
can't speak for the whole mozilla community though :-)
(Assignee)

Comment 33

19 years ago
Taking the hint ... Will raise the issue in n.p.m.ui, and reassign to slamm when 
the group has come to some semblance of a decision. If that's not what you meant, 
German, then reassign back to yourself.
Assignee: german → mpt
Status: ASSIGNED → NEW
Whiteboard: [PDT-] → [PDT-] -- to be discussed in n.p.m.ui

Comment 34

19 years ago
Since 90% of the tabs that people use will be web pages which are single click, 
I vote for single click for mozilla.  However, for Netscape branded, we will in 
general use single-click but make exceptions for particular tabs that require 
double-click for their functionality.  German and I agree on that.

Comment 35

19 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.

Comment 36

19 years ago
any update on this bug

Comment 37

19 years ago
Isn't this fixed with bug 41609 ?

Comment 38

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Comment 39

18 years ago
FWIW, Robert no longer works at Netscape, and may not even be involved in
mozilla.org anymore.

Comment 40

18 years ago
Clearing very old milestone (M16) in hope of reevaluation.
Target Milestone: M16 → ---

Updated

18 years ago
Blocks: 104166

Updated

18 years ago
Depends on: 41609, 55553, 71661

Updated

18 years ago
Depends on: 113735

Comment 41

18 years ago
cc'ing tpringle, sgehani & adding UI keyword. I don't understand how we still
require so many double-clicks in sidebar panels, especially for the dominant
operations that should be easiest to do.  All the UI owners and tested users
were in agreement on this at one point; why does the sidebar still have the
deprecated behavior?
Keywords: ui
Whiteboard: [PDT-] -- to be discussed in n.p.m.ui → -- to be discussed in n.p.m.ui

Comment 42

18 years ago
I agree with Peter here.  Frankly IE does this the right way in my opinion.  It
is a single click to open favorites folders/history folders and a single click
(shown as a link) to access the favorites/history sites.  This is what most
average end users expect I believe.  

I would also guess that many find the "twisty" concept confusing as well as it
is not part of the most common OS, Windows.  Plus they take up valuable
horizontal space where real estate is at a premium.

My only other concern is that we are consistent across the application (i.e.
Mail, IM) to the extent that consistency makes sense. 

Comment 43

17 years ago
This is fixed, now.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 44

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.