Junk mail not moved to Junk folder if first moved to Local Folders

RESOLVED DUPLICATE of bug 180153

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 180153
15 years ago
9 years ago

People

(Reporter: Eyal Rozenberg, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030502
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030502

I have a set of mail filters which moves everything from the inbox folder of my
mail account to different folders in my Local Folders, so that a catch-all
filter at the bottom of the list moves any remaining messages to 'Inbox' on
Local Folders. Although Junk mail is identified correctly, it is never moved to
the Junk folder and stays in the Local Folders inbox. I suspect this is due to
the fact that the move to the Junk folder is only made if the message has not
been handled/moved by a mail filter.

Note that I'm talking about _all_ Junk messages, not just _some_, like in
http://bugzilla.mozilla.org/show_bug.cgi?id=196732


Reproducible: Didn't try

Steps to Reproduce:
1. Set up a mail filter to move all messages to the Inbox on your Local Folders
2. (Expect to) see Junk mail messages in Local Folders inbox
3.

Comment 1

15 years ago
*** Bug 204852 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Not sure about this, but I think this may be "by design".  The junk mail setup
dialog only applies to remote accounts - they don't seem to apply to local folders

Updated

15 years ago
Summary: Jumk mail not moved to Junk folder if first moved to Local Folders → Junk mail not moved to Junk folder if first moved to Local Folders
(Reporter)

Comment 3

15 years ago
Aargh! Beaten by 2 measly bug indices! I reported this as 204852... I see this
bug also. So, QA people, please make this 'NEW'.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 180153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.