[CRASH] while printing dogfood email

VERIFIED DUPLICATE of bug 20504

Status

MailNews Core
Printing
P1
normal
VERIFIED DUPLICATE of bug 20504
18 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: dcone (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
when i tried to print the responding email from dogfoodsnack@netscape.com,
Seamonkey crashed. strangely enough, the email did successfully print!

occurred with build 1999-12-01-09-m12 on WinNT.

1. start Mozilla. send email to dogfoodsnack@netscape.com.
2. start mail in mozilla (Messenger) and open responding email from
dogfoodsnack.
3. press the Print icon/button. Print dialog appears, click OK.

expected: dialog should happily go away, and mozilla (navigator, messenger and
other windows that might be up) should remain open and available for use. :-)

result: Dr Watson msg. mozilla crashes. but i go to the printer and the email
message is printed anyway... maybe not related to Printing component? here's
the Talkback trace info (incident # 1578469).


 Trigger Type:  Program Crash

 Trigger Reason:  Access violation

 Call Stack:    (Signature = nsViewManager::ViewToWidget 5004295b)

   nsViewManager::ViewToWidget

[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2724]

   nsViewManager::AddRectToDirtyRegion

[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2257]

   nsViewManager::UpdateView

[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1426]

   nsViewManager::UpdateView

[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1417]

   nsViewManager::RemoveChild

[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1835]

   nsView::~nsView

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 134]

   nsView::`scalar deleting destructor'


   nsView::Destroy

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 257]

   nsFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 374]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
98]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
97]

   ViewportFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line
138]

   FrameManager::~FrameManager

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 341]

   FrameManager::`scalar deleting destructor'


   FrameManager::Release

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 329]

   PresShell::~PresShell

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 587]

   PresShell::`scalar deleting destructor'


   PresShell::Release

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 520]

   nsCOMPtr_base::~nsCOMPtr_base

[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 45]

   DocumentViewerImpl::PrintContent

[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 658]

   DocumentViewerImpl::PrintContent

[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 588]

   DocumentViewerImpl::DocumentReadyForPrinting

[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 922]

   DocumentViewerImpl::Print

[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 1167]

   nsMessenger::DoPrint

[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMessenger.cpp, line 1408]

   XPTC_InvokeByIndex

[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 139]

   nsXPCWrappedNativeClass::CallWrappedMethod

[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp,
line 895]

   WrappedNative_CallMethod

[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 192]

   js_Invoke

[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 524]

   js_Interpret

[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2210]

   js_Invoke

[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 546]

   js_Interpret

[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2210]

   js_Invoke

[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 546]

   js_Invoke

[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 621]

   JS_EvaluateUCScriptForPrincipals

[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2707]

   nsJSContext::CallFunction

[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 472]

   nsJSEventListener::HandleEvent

[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 134]

   nsEventListenerManager::HandleEventSubType

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
626]

   nsEventListenerManager::HandleEvent

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
765]

   nsXULElement::HandleDOMEvent

[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 2580]

   nsEventStateManager::CheckForAndDispatchClick

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
1386]

   nsEventStateManager::PostHandleEvent

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
654]

   PresShell::HandleEvent

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2462]

   nsView::HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 841]

   nsViewManager::DispatchEvent

[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1678]

   HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]

   nsWindow::DispatchEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 441]

   nsWindow::DispatchWindowEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 458]

   nsWindow::DispatchMouseEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3466]

   ChildWindow::DispatchMouseEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3682]

   nsWindow::ProcessMessage

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2774]

   nsWindow::WindowProc

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 625]

   USER32.dll + 0x1820 (0x77e71820)



 Registers:
 EAX:
      00000000
                       EBX:
                            00000000
                                              ECX:
                                                  0012ed38
                                                                    EDX:

0012ed38
 ESI:
      0012ed50
                       EDI:
                            0012ed60
                                              ESP:
                                                  0012ed0c
                                                                    EBP:

0012ed30
 EIP:
      602f81e9
                       cf PF af ZF sf of IF df nt RF vm   IOPL: 0

 CS:
     001b
              DS:
                 0023
                           SS:
                              0023
                                       ES:
                                           0023
                                                    FS:
                                                        0038
                                                                 GS:
                                                                    0000
(Reporter)

Updated

18 years ago
Priority: P3 → P1
Summary: crash while printing dogfood email → [CRASH] while printing dogfood email
Target Milestone: M12

Comment 1

18 years ago
This is a duplicate bug of another one assigned to dcone.  You also crash
printing from the browser too.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
marking as a duplicate of 20504

*** This bug has been marked as a duplicate of 20504 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
verified
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.