If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Canvas background is not set correctly

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
P2
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Antti Näyhä, Assigned: troy)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
NGLayout Dec-23 nightly build (Win32) renders the test page incorrectly:
The whole canvas including margins should be light blue, not just the BODY
element background.

The relevant section of the spec is:
http://www.w3.org/TR/REC-CSS1#the-canvas

Updated

19 years ago
Assignee: peterl → troy
(Assignee)

Updated

19 years ago
Assignee: troy → peterl
(Assignee)

Comment 1

19 years ago
Peter, after reading sections of the spec that David Baron pointed out I
think the correct thing to do is to have the background rendered on the HTML
element if the HTML element's background is transparent.

http://www.w3.org/TR/REC-CSS1#the-canvas
http://www.w3.org/TR/REC-CSS2/colors.html#q2

That approach seems better than trying to force the BODY frame to take up all
the available space.

Getting the background style info to correctly reflect how rendering should
work, i.e., have the HTML element paint the background if possible, would be
best if it were handled through style, rather than having the frames try and
figure it out at rendering time. In particular, because the frames used for the
HTML element and the BODY element are just regular old frames and have no
knowledge that they need to render specially.

That seems like the cleanest way to do it, but I don't really know what the
proper way for that to happen.

If you don't want to do that (or you don't agree that's the best way to
handle it), I at least need you to suggest how to go about doing that
(Assignee)

Updated

19 years ago
Assignee: peterl → troy
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
Now we do what the spec suggests and if the HTML element's background is
'transparent' then we use the BODY's background property
(Assignee)

Comment 3

19 years ago
*** Bug 2073 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Verified fixed using 1.28.99 builds on Mac OS, Win32 & Linux. Thanks, Antti!
You need to log in before you can comment on or make changes to this bug.