Closed Bug 2055 Opened 21 years ago Closed 18 years ago

[BLOCK] compact DL should be supported

Categories

(Core :: Layout: Block and Inline, enhancement, P5)

enhancement

Tracking

()

VERIFIED WONTFIX
Future

People

(Reporter: dbaron, Assigned: attinasi)

References

(Depends on 1 open bug, )

Details

(Keywords: relnote, testcase, Whiteboard: [bae:20011119]relnote-devel hit during nsbeta2 standards compliance testing)

Once you get child selectors working, you can get compact DLs by putting the
following in ua.css:

DL[COMPACT] > DT {display: compact; }

See the above URL.
Setting all current Open/Normal to M4.
QA Contact: 4110 → 1698
[QA Assigning to self.]
QA Contact: 1698 → 4110
[Oops. Reassigning back to chrisd; misread this as a list issue, rather than a
style sheet issue. Thanks for pointing that out, Chris.]
Assignee: peterl → kipp
We have the child selectors now. What we really need is compact layout...
You've supported compact display for a while now too:

http://www.fas.harvard.edu/~dbaron/csstest/results
Severity: normal → enhancement
Status: NEW → ASSIGNED
Priority: P2 → P5
Summary: compact DL should be supported → {feature} compact DL should be supported
*** Bug 4740 has been marked as a duplicate of this bug. ***
Whiteboard: [TESTCASE]
Simplest possible testcase:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<HEAD>
<TITLE></TITLE>
</HEAD>
<BODY>
<OL compact>
  <LI>List item 1
  <LI>List item 2
  <LI>List item 3
</OL>

<OL>
  <LI>List item 1
  <LI>List item 2
  <LI>List item 3
</OL>
</BODY>
</HTML>

Marking as testcase...
Severity: normal → enhancement
Priority: P3 → P5
Target Milestone: M17 → M20
Blocks: html4.01, 15432
OS: other → All
Hardware: Other → All
Summary: {feature} compact DL should be supported → {css2} {feature} compact DL should be supported
What's happenning now is that 'display:compact' is being treated as block.

For final release, this should not happen.  Rather than treat it as block, you
should ignore it.  This means that the style system should treat it as an
invalid keyword, so that

   h2 {
     display: block;
     display: compact;
   }

...yields block display, and

   dl {
     display: inline;
     display: compact;
   }

...yields inline display.

This last issue is now covered by bug 15432. I am marking that bug dependent on
this one, but technically it is an either|or situation.

Note: For HTML4 compliancy, we should support 'compact'.
Assignee: kipp → pierre
Status: ASSIGNED → NEW
Updating to default Style System Assignee...kipp no longer with us :-(
Summary: {css2} {feature} compact DL should be supported → {css2} {feature} [BLOCK] compact DL should be supported
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
Summary: {css2} {feature} [BLOCK] compact DL should be supported → {feature} [BLOCK] compact DL should be supported
Whiteboard: [TESTCASE]
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
Display:marker/run-in/compact are not supported. Closed as Later like bug 2056 
and bug 14983.

The parser drops any declaration that contains one of these display types (see 
bug 15432).
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → LATER
Does not supporting DL COMPACT mean Mozilla will not have 100% HTML 4.0 
compliance for final release? If so, should that be on the release notes (relnote 
keyword)?
mpt: You are correct. BTW, you can see the list of HTML4 features which we will 
NOT be implementing by looking at the bugs blocking 7954 that are marked LATER.
Keywords: relnote
Not supporting this does *NOT* imply noncompliance with HTML 4.0.  HTML 4.0
neither describes the expected rendering nor requires that the rendering be
different.  The most it says about the attribute is:

  When set, this boolean attribute gives a hint to visual user agents to render
  the list in a more compact way.
  (from http://www.w3.org/TR/REC-html40/struct/lists.html#h-10.2 )
Verified LATER
Status: RESOLVED → VERIFIED
Reopening and moving to Future...
Status: VERIFIED → REOPENED
Resolution: LATER → ---
Target Milestone: M20 → Future
Keywords: correctness
QA Contact: chrisd → py8ieh=bugzilla
Summary: {feature} [BLOCK] compact DL should be supported → [BLOCK] compact DL should be supported
Whiteboard: hit during nsbeta2 standards compliance testing
*** Bug 50195 has been marked as a duplicate of this bug. ***
Whiteboard: hit during nsbeta2 standards compliance testing → relnote-devel hit during nsbeta2 standards compliance testing
Matty: Why do you think this is a mozilla0.9 blocker?

This is a CSS2 RFE, I wouldn't even put it down as a mozilla 1.0 blocker.
Probably the "correctness" and "relnote" keywords, but perhaps I was a little
trigger-happy.

I'll respect whatever opinion you have, but I think it should probably be
nominated for 1.1 or 1.2 at least.
A CSS2 RFE? Um, it's expected behavior (regardless of what is *required* 
behavior) for HTML 2.0 (regardless of whether or not an HTML 2.0 rendering engine 
uses CSS to present HTML at all).
Nominating for nsbeta1 consideration because you do encounter pages from time 
to time that depend on this behavior and look strange (text lines spaced out 
widely) because it's not supported. However, if Netscape engineering runs out 
of time before nsbeta1, this would be a good one to FUTURE.
Keywords: nsbeta1
Nominating this bug for nsbeta1 on behalf of gerardok@netscape.com.
Build reassigning Buster's bugs to Marc.
Assignee: buster → attinasi
Status: REOPENED → NEW
Blocks: 104166
the compact attribute has been deprecated since HTML 4.0 and is obsoleted in 
XHTML.

this should be a wontfix
Status: NEW → RESOLVED
Closed: 20 years ago18 years ago
Resolution: --- → WONTFIX
Whiteboard: relnote-devel hit during nsbeta2 standards compliance testing → [bae:20011119]relnote-devel hit during nsbeta2 standards compliance testing
    Personally, I don't agree with the WONTFIX. If there was any other practical
way to do the same kind of formating as <DL COMPACT>, that would be OK, but
there is just no way to do it. The HTML I "write" is very basic designed for
*any* browser, including Lynx, so I don't want any XHTML or CSS solution.

    Let's take a concrete example : I've got a few papers on my web page, and at
the end of the paper I've got a list of references :
http://www.hpl.hp.com/personal/Jean_Tourrilhes/Papers/Packet.Frame.Grouping.html#References
    <Comments on my buggy HTML for another day please>
    The formating that I want is something like :
-------------------------------------
[1]     IEEE 802.11 : Wireless LAN medium access control (MAC) and physical
layer (PHY) specifications. IEEE.
-------------------------------------
    There is no notion of <TAB> or <OL> with customised headings, so I do :
---------------------
<dl COMPACT>
<dt>[1]
<dd><i>IEEE 802.11&nbsp;: Wireless LAN medium access control (MAC) and
physical layer (PHY) specifications</i>. IEEE.
---------------------
    Which is to me both logically and esthetically pleasing. Logically, because
it's a list of attibute/value pairs, which is exactly what <DL> is supposed to
mean. Esthetically because it display like a <OL> list.
    All browser I tested support this the way it should be, except of course
Mozilla that break it in two lines (ugly).
    Now, I'm pretty ignorant about HTML and all the jazz, but if you find me a
solution that would produce the same effect a <DL COMPACT> and works in all
browsers, I'm with you. Otherwise, I just have to disagree...
    FUTURE is ok with me, it doesn't have to be fix *right now*, it can wait 1.1
or later, but I just disagree in you saying it's not worth fixing (and that's
why I voted for this bug).
    <By the way, what's involved in fixing that ? It seems that both front-end
and back-end for it are already implemented ?>
    Jean
Sorry, I thought I had explained that I marked this as wontfix based on the 
deprecation of this attribute in HTML 4.0 Spec and the obsoletion of the 
attribute in the XHTML Spec. I guess we could reopen, keep in future and mark it 
as a quirks only issue. 
*** Bug 111936 has been marked as a duplicate of this bug. ***
ok
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: [BLOCK] compact DL should be supported → [BLOCK] compact DL should be supported in quirksmode
Please don't make quirks mode and standards mode diverge any more.  Standards
mode should follow the standards -- and implementing deprecated features is
certainly within the standards.  Quirks mode should only differ from standards
mode when we *need* to break standard behavior in order to get real pages on the
web to display correctly.

Having said that, I think wontfix is an appropriate resolution here since we've
removed our support for 'display: compact' and since compact DLs aren't used on
the web and are deprecated.  When i initially filed this bug it would have taken
a single rule in ua.css to fix this bug.
Summary: [BLOCK] compact DL should be supported in quirksmode → [BLOCK] compact DL should be supported
I'm with David on this one, reclosing as wontfix
Status: REOPENED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → WONTFIX
*** Bug 133022 has been marked as a duplicate of this bug. ***
VERIFIED that we have decided not to support HTML 3.2's "compact" attribute on
DL elements.
Status: RESOLVED → VERIFIED
<DL COMPACT> is deprecated, but not obsolete in HTML 4.01.
Deprecated attributes should still be rendered in browsers for backward 
compatibility.

Is there a way to specify compact rendering of DL in style-sheets?
I fear not!  One more reason to still support <DL COMPACT>.

Aaron Swarz (comment #7) is wrong by supposing COMPACT an attribute of OL 
instead of DL

I agree with jt@hpl.hp.com (comment #27) that this bug should NOT be a WONTFIX 
as COMPACT DL helps a lot when dealing with lists - I too use(d) this attribute 
a lot.

I disagree with David Baron (comment #31) believing compact DLs aren't used on 
the web.  I even hope, compact DL will be put back in the standard and be used 
*more*, instead of the widespread use to put cumbersome nested tables everywhere 
to control layout...
*** Bug 133022 has been marked as a duplicate of this bug. ***
beppe@netscape.com wrote "I marked this as wontfix based on the 
deprecation of this attribute in HTML 4.0 Spec and the obsoletion of the 
attribute in the XHTML Spec".

On the other hand Netscape's developer release notes
<URL:http://developer.netscape.com/docs/technote/gecko/n6release.html> classify
this bug as a CSS2 issue.

This thread has gotten very muddled and has over time raised issues from child
selectors to support of "display: compact" to support of the
(deprecated/obsolete) compact attribute. There should really be separate bugs to
track these separate issues.  The last few comments as well as most (all?) of
the duplicate bug reports are about the compact attribute, so I think the
following actions should be taken:

- Create a new bug report to track work on a future "display: compact"
enhancement (I don't see an existing specific bug report for this purpose).

- Make it clear that this bug is now only for the compact attribute. And remove
css2 from the keywords if that is possible.
bug 180468 is the inline: compact not implemented css2 bug.
Keywords: css2
*** Bug 203489 has been marked as a duplicate of this bug. ***
Component: Layout → Layout: Block & Inline
Depends on: 180468
*** Bug 234027 has been marked as a duplicate of this bug. ***
This bug should really be reopened, as it is not only an HTML bug, but also a
CSS2 bug. As a deprecated HTML feature, Mozilla could drop support for the <dl
compact> form, but if the {display: compact} support is not achieved, Mozilla
will never be  able to claim CSS2 compliance (nearly six years after, now...).
'display:compact' should be a separate bug.
And it is - bug 180468
You need to log in before you can comment on or make changes to this bug.