multiple generic fonts (monospace / non-monospace) cause wrong size

RESOLVED DUPLICATE of bug 175415

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 175415
15 years ago
11 years ago

People

(Reporter: Yuying Long, Unassigned)

Tracking

(Depends on: 2 bugs, {css1})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Build: 05-13 trunk build on All platforms

Steps to reproduce:
1. Go to page: http://www.w3.org/Style/CSS/Test/CSS1/current/sec522.htm
2. Please compare the fonts display in ".five {font-family: monospace;}" and
".seven {font-family: monospace,serif;}" section are differently.
- I expected them are displayed same; IE and Sarafi have the same display with
these two.
Created attachment 123167 [details]
testcase

Confirming problem (NS7/Pheoenix/current mozilla build), the two lines display
differently because the font-size applied isn't the same. The <p> which has
rule .seven {font-family: monospace,serif;} is displayed on screen in a
monospace font but with the font-size set in prefs/appearance/fonts for
proportional fonts.

To see the bug you have to set different font-size for monospace and
proportional fonts in preferences (default configuration I think).

Updated

15 years ago
Keywords: css1
I think the basic problem here is that we have bugs when we have multiple
generic fonts at the end of the font list.  I thought we had other bugs filed on
that, but I can't find any.
Assignee: font → dbaron
Component: Layout: Fonts and Text → Style System
Summary: Monospace font in CSS is not displayed properly → multiple generic fonts (monospace / non-monospace) cause wrong size

Comment 3

15 years ago
Yep, it is a dup of bug 79074 (although its summary isn't suggestive of that). 

*** This bug has been marked as a duplicate of 79074 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Undupping on further thougths, it might be easier/clearer to leave this bug on
its own.

The issue is the parsing of multiple "generic1, generic2" which has been
mentioned on several occasions but hasn't got a distinct thread so far.
Status: RESOLVED → REOPENED
Depends on: 79074
Resolution: DUPLICATE → ---

Comment 5

15 years ago
a distinct thread so far ...apart from bug 78517.
Depends on: 78517

Comment 6

13 years ago
Is it dup of (or at least linked to) bug 175415 ?
Depends on: 159440

Updated

11 years ago
Depends on: 175415
Assignee: dbaron → nobody
Status: REOPENED → NEW
QA Contact: ian → style-system

Comment 7

11 years ago
Yes, Mathieu: you are perfectly correct. This bug is a DUPLICATE of bug 175415. This bug is not a duplicate of bug 79074.

The nice thing about this bug 205537 is that there is a good testcase webpage coming from the current CSS1 test suite which could serve as a testcase here.

I believe we should resolved bug 205537 as duplicate and then resummarise bug 175415; one reason why is that discussion over at bug 175415 has been well developped for some time.

Comment 8

11 years ago
> bugs when we have multiple generic fonts at the end of the font list.  
> I thought we had other bugs filed on that

Resolving as DUPLICATE of bug 175415
Status: NEW → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 175415
You need to log in before you can comment on or make changes to this bug.